Kee (pass) is showing big red OFF logo and I cannot open it


#1

OFF logo has appeared.

OS Linux Mint 18.2 Sonya. Firefox 57 just upgraded and Kee version 2.0.0.25

Cannot find a way to open or import database to new Firefox.

Help appreciated.

Stephen


Kee doesn't work, just showing "OFF" logo
Key is always on "off"
No search or list of logins in panel/popup/dropdown
#2

See No search or list of logins in panel/popup/dropdown


#3

What happens when you start KeePass like a normal program?


#4

Same for me, on Ubuntu 16.04.3 64-bit, KeePass 2.37, Kee 2.0.0.25, Firefox 57.0, Only colored Kee logo displayed with big red ‘OFF’ overlay.

Starting KeePass normally nothing changes.
Database is opened in KeePass, but Kee doesn’t see this.
KeePassRPC version is 1.7.3 (latest from GitHub).
Port is same in Kee and KeePassRPC. Settings were migrated from KeeFox extension, maybe this is problem with some old (incompatible) settings?

How can I debug this?


#5

Hi,
i’m using mint 18.2 too and i never had this problem.
Just follow these instructions step by step

# add ppa repo to access latest version of KeePass
sudo add-apt-repository ppa:jtaylor/keepass

# update local repo details to ensure the latest KeePass is selected later
sudo apt-get update

# Install Mono
sudo apt-get install mono-complete

# Install KeePass
sudo apt-get install keepass2

# Create plugins folder
sudo mkdir /usr/lib/keepass2/plugins

# Install curl and jq (required only for ease of installing the latest version of KeePassRPC)
sudo apt install curl
sudo apt install jq

# Put the latest version of KeePassRPC into the plugins folder created earlier
curl -s https://api.github.com/repos/kee-org/keepassrpc/releases/latest | jq -r ".assets[] | select(.name | test(\"KeePassRPC.plgx\")) | .browser_download_url" | xargs sudo curl -s -L -o "/usr/lib/keepass2/plugins/KeePassRPC.plgx"

#6

confirmed flaky under windows, too.

[The Problem from an user standpoint]:

the big mf problem is it disrupt the workflow

you have to crash all your tabs and windows and restart everything because
and you can not do anything apparently.

(tell me something about working with this under high pressure production environment)

confirmed that under high security this s**t happens

[exact bug from a power user standpoint:]

Kee - from the UI side - does not “get” that keepass2 is still running and with a valid open db.

On the contrary, keepass2 received req from an app called “Kee” to issue new code.

[Proposed soution]

Please, make Kee bulletproof, so that we can put that code to the window as necessary without disrupting our precious workflow


#7

I am seeing the same thing.

It seems to happen most often if KeePass exits then restarts without Firefox restarting.
When KeePass starts, the OFF icon will change from red to amber, so the plugin knows that KeePass is running, it just can’t tell that the database is unlocked.

Closing Firefox completely and reopening will usually clear the problem. I have also found that disabling/enabling the plugin will sometimes clear the problem without having to close Firefox.

Windows 7
Firefox 57.0.2 (64bit)
KeePass 2.37
Kee 2.0.0.25


#8

Workaround (so you do not have to disrupt your productivity workflow even more;

Workaround for a serious bug - Kee not opening code field window (although Keepass2 reports that Kee asked for it and issued new code);

-When Keepass display a code - deny access.
that will trigger another code reissue, and hopefully Kee will be able to catch it up this time and open the code entry window.

Hope it helps.


#9

Kee doesn’t work, just showing “OFF” logo and message “You are not logged in to your password database”, but I am logged. KeePass enabled, connection between keepass and kee established.
Windows 10
KeePass: 2.37
Kee: 2.0.0.25
Firefox: 57.0 (64 bit)
изображение


#10

I have exactly the same issue. I am getting nuts with it.
Windows 10
KeePass: 2.37
Kee: 2.0.0.25
Firefox: 57.0 (64 bit)
KeePassRPC 1.7.3

have you figured out a solution?


#11

Hello,
since the upgrade to the newest firefox (57) my kee / keefox is not working. Keepass is startet and the database is loaded. Now I get a big red OFF with the message, that I didn’t opened a database.
My System: Windows 10 64Bit, Firefox 57

Does somebody have a solution?

Thanks

Gb4u


#12

I’ve just added a new documentation page containing updated troubleshooting information, including advice on how to resolve the problems discussed in this thread.


#13

There was nothing in my troubleshooting guide (v2.38) about this issue I checked. Issue remains kee reports “Big Red OFF” despite being logged into keepass Any assistance with this would be appreciated.

Best Regards

Vi0let


#14

Also had similar problem of Kee not being able to connect to KeePass and I just resolved it. So Iam sharing how I fixed it.

Waterfox 56.0.3 (64-bit)
Windows 10 (64-bit)

In my case it was another addon issue.
I was running discontinued RequestPolicy 0.5.28.1-signed.1-signed (https://addons.mozilla.org/en-US/firefox/addon/requestpolicy/). I had no idea that this version was discontinued (installed it some time ago).

And even though I read all the troubleshooting tips which mention to whitelist things in other addons, which I did in every possible addon I have.
Whitelisting it in the outdated RequestPolicy wouldnt help at all .
Installing “RequestPolicy Continued” (https://addons.mozilla.org/en-US/firefox/addon/requestpolicy-continued/) would simply resolve the issue.
Think the new RequestPolicy did read the whitelisted items from the old version, so whitelisting might also be needed.
(Whitelist: Allow 127.0.0.1:12546)

Anyways I first had to find out if its actually addon causing this, and if yes then which one.
Good way (IMO) seems to be simply disabling all addons and trying Kee.
If it works, enable some of your disabled addons and check again. If it works, enable more and check again, until it stops working, then you have much narrower choice of problematic addons.
If it doesnt work with addons disabled, its most definitely not an addon causing it.

I know those are pretty basic troubleshooting steps, but maybe it would be nice to mention such way in troubleshooting info.

I can see you guys here seem to all have Firefox 57.x so you might have another issue and this might be completely useless.
But thought I throw this out there, especially because RequestPolicy is mentioned in troubleshooting along with what to do, yet I still stumbled into such situation, which might make you first assume that RequestPolicy is not at fault after whitelisting. ( surprise, surprise xD )

Good luck ya all :stuck_out_tongue:


#15

I’m using Kee on Windows 10 with Comodo Internet Security Premium 10. I’ve had a number of issues using Kee to access a different password database within the Virtual Desktop sandbox. As a result I now run two separate instances: one a normal installation and one a portable version for use in the sandbox.

But when there is an upgrade, despite carefully clearing the sandbox, updating both versions and checking that all the ports are correct, I still sometimes encounter this red OFF logo problem. When all else fails to clear it, I usually find that what works is to close Firefox, open the tray on Kee, select Tools/KeePassRPC (Keefox) Options/Authorised Clients and revoke all existing authorisations. Next time I try to connect, I’m asked for the authorisation code. I then have to find this (sometimes the window is hidden by other stuff), and enter it. After that, all seems to work well till the next update. I find it very time-consuming and annoying, though, and would love to find an easier way of doing this.


#16

Hello,

I’ve just installed key as add-on on Mozilla 57.0.4.

I don’t know why it’s always “off”.

I’ve no place to login.

I’ve that above the applet : “You are not logged in to your password database. Launch KeePass to enable Kee”

So what can I do to resolve this problem?


#17

I’ve same problem with:

  • Firefox 58.0 x64
  • Linux Mint 18.3 x64
  • Keepass 2.37

#18

+1
KeePass 2.38
Mint 18.3
FF 58.0 x64


#19

Update, to mine running windows 10 pro 64 bit in firefox 58.0.1 64 bit and any previous version of same the RPC plugin was missing in my INSTALL directory in the plugins folder a simple download later and voila’ works perfect.

Special thanks to Luckyrat fur bein awsome and all the community, much appreciated

thank you

Vi0let ^.^


#20

I have the same problem. Is there an easy fix?

Win 10 pro 64 Firefox 58…