Infinite page loading loop when Kee auto-fills a login form


#1

Hi,

First, thanks you so much for this addon and for the new version <3

I’m encoutering a bug while trying to login on my webmail (https://webmail.gandi.net/) :
Kee recognise the form, fill up information and send the form. But it looks like it fails to send it properly and the page is reloaded instead.
I tried to catch HTTP request, but my console stays empty, so i’m guessing there is no AJAX, just a good ol’ POST request with PHP on this web application.

Any idea what could be the orgin of the problem ?


#2

Same for me, but on an internal sw packaged based web server.
Might be able to help test an fix/update if you want.

Br
Stef


#3

Same for me, on this page: https://www.virtualbrokers.com/en-us/client-login


#4

Same for me on this page - https://direct.credit-suisse.com/dn/c/cls/auth?language=de

Any clue why, or any solution in the making?


#5

Same for me on this page - https://webmail.df.eu


#6

I’ve looked into each of the URLs mentioned here (and at Kee is autosubmitting some entries). I’m glad to say that all can be fixed immediately by you deleting a single piece of form field information from your password database. In the longer term, I have identified a change that could be applied to Kee in order to avoid this manual fixup in your database but it will probably be a while before I can verify that this won’t have any detrimental effects on other login forms and then find the time to implement it.

In general, if you find this infinite reload happening to you when you do not have any auto-submit option enabled, you can resolve it one of two ways:

  1. Remove non-essential (often context or language dependent) options from the KeePass entry that is causing the website to reload in this way.

    1. Edit the entry
    2. Select the Kee tab
    3. Select the Form fields tab
    4. Delete the relevant field in the list (often identifiable by being of Type “Select” or having a Name or Id referring to “Language”, “Culture” or “Mode”)
    5. Click OK and then reload the page in your browser to verify that the fix has worked
  2. Disable auto-fill for the affected KeePass entry.

    1. Edit the entry
    2. Select the Kee tab
    3. Change the Auto-fill Entry-behaviour to “Never”
    4. Click OK and then reload the page in your browser to verify that the fix has worked

More specific details for the websites already mentioned are below.

https://webmail.gandi.net

Cause:

onchange attribute on language select field

Workarounds:

  • Disable auto-fill
  • Delete the _lang_sel form field from the KeePass entry > Kee > Form fields list

Potential Kee changes to avoid the need for these workarounds in future:

  • Only fire oninput and onchange events when the value has actually been changed
  • Don’t fire onchange events when they are defined by attributes that directly invoke HTTP GET requests

https://www.virtualbrokers.com/en-us/client-login

Cause:

onchange attribute on language select field

Workarounds:

  • Disable auto-fill
  • Delete the dnn$dnnLANGUAGE$selectCulture form field from the KeePass entry > Kee > Form fields list

Potential Kee changes to avoid the need for these workarounds in future:

Only fire oninput and onchange events when the value has actually been changed

https://direct.credit-suisse.com/dn/c/cls/auth?language=de

Cause:

onchange attribute on language select field (hidden unless on narrow mobile phone view)

Workarounds:

  • Disable auto-fill
  • Delete the languageSelect (ID) form field from the KeePass entry > Kee > Form fields list

Potential Kee changes to avoid the need for these workarounds in future:

Only fire oninput and onchange events when the value has actually been changed

https://webmail.df.eu/login.php

Cause:

onchange attribute on webmail_mode select field

Workarounds:

Delete the webmail_mode form field from the KeePass entry > Kee > Form fields list

Potential Kee changes to avoid the need for these workarounds in future:

Only fire oninput and onchange events when the value has actually been changed

https://webpro-lin.demo.plesk.com:8443/login_up.php

Cause:

onchange attribute on language select field

Workarounds:

  • Disable auto-fill
  • Delete the locale_id form field from the KeePass entry > Kee > Form fields list

Potential Kee changes to avoid the need for these workarounds in future:

Only fire oninput and onchange events when the value has actually been changed


Auto submitting with Captcahs
Kee is autosubmitting some entries
Kee does not work - downgraded to KeeFox 1.7 and Firefox 56
#7

Yes !!! Does fix Virtual Broker. Thanks a lot.


#8

Thank you! That set it straight for df.eu. :+1:

Cheers
Philipp