Basic HTTP Authentication not working (when on corporate proxy)


#1

Using Kee 2.3.19.1, Firefox 59.0.3 (64-bit), Windows 7 (64-bit), KeePass 2.38 and KeePassRPC 1.8

Since updating to Kee 2.0 on Firefox 57, automatic login using sites using HTTP-auth has never worked for me and is still not working to this day.

Unlike questions like Basic auth not filled correctly (Kee 2.0.0.25 Ubuntu 56.0 64bit) and Priorities with HTTP basic auth this issue is definitely not caused by an incorrect domain configuration. They worked fine in FF56 and the old KeeFox extension. Additionally, Kee correctly finds the single login associated with the sites and lets me pick it in the dialog…

nwauth

However, when choosing that login, I am still presented with a standard Firefox authentication prompt that’s empty.

The same thing occurs when ticking the option “When Kee finds only one matching network login (e.g. HTTP Auth), automatically login” in Kee’s options page. No Kee dialog is shown, but I still get the prompt.

I’ve tried updating KeePassRPC, uninstalling and reinstalling Kee. What’s even stranger is that this works correctly on another machine using the same OS and Firefox version.

Do you think it could be something to do with my company’s corporate proxy settings? Firefox is set to “Use system proxy settings”. This corporate proxy requires a username and password of its own, and sometimes Firefox sees ‘407 Authentication Required’ responses for requests while subsequent requests will work correctly. Perhaps Kee cannot cope with this. What else can I do to diagnose the issue, and if it turns out to be the proxy, could you perhaps implement a workaround for it in future?


#2

Almost certainly. Firefox 57 removed support for addons to work with proxies. Versions since have made various failed attempts to enable this support again but none have yet delivered the required bug-free functionality that Kee would require in order to work with proxies.

This issue has been tracked on GitHub for a while along with some code that attempted to utilise some of the changes in FF58/59 but the work is essentially paused now until Mozilla have got their side of things sorted out. I’ve just posted an update to the issue - they are still actively fixing issues so there is hope that a solution is only a matter of months away now.


#3

OK, fair enough! I had a look through that issue and I saw people using logins for the moz-extension:// protocol. Do you think that would help at all?


#4

I think moz-proxy:// is the protocol they were using and it didn’t work. moz-extension is the protocol to identify a specific Firefox add-on and I think is only making it into that discussion because it is visible in the popup dialogs that Kee asks Firefox to produce so I don’t see how that could help either.