Upgrade to Kee 2.0 breaks link to KeePass


#1

When I opened Firefox, KeeFox just has a big red OFF sign on the icon and I cannot get it to connect to KeePass. I have re-installed KeePassRPC 1.7.3. Firefox version is 56.0.2.

The firefox debug shows this message - “Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
Reading manifest: Error processing version_name: An unexpected property was found in the WebExtension manifest.”


Help and support
#2

No break here.
Precision : keepass was closed during upgrade. I opened it and all seems fine.


#3

Same here, big RED off, a PopUp wich tells me to authorize a new connection … into the box knee presented to you.
But, no Box, only an empty tab to moz-extension://6aa8ebcd-ce7e-4f5e-a99e-6b3a0328aa27/dialogs/SRP.html
Yes, restarted FF, uninstalled KEE, reinstalled Kee, same behavior

Do i need latest FF? i have 56


#4

And Firefox shortcut STRG + Shift + 2 for getting KeePass login dialog isn’t working…


#5

In theory 56 should work fine, in practice only 57 has been thoroughly tested and I am 100% certain there are Firefox bugs in 56 that will cause problems from time to time - especially on Linux and Mac. Unless there’s a critical problem that prevents you from upgrading to 57, I’d advise doing so soon - it’s much faster than 56 and generally much better once you get used to the user interface changes and forced changes for many add-ons

That’s expected and not a problem.

That won’t work if KeePass is not running (Firefox prohibits that now) but it should work for unlocking when KeePass is open. I’m assuming STRG is an alternative key for CTRL?


#6

Ok. I will test again when I upgrade to 57. Not ready to yet. FF57 will break almost every plugin that I use on a regular basis.


#7

Works great with FF57 but since other Plugins like my No One Plugin TabMixPlus are not working i must switch back to the old KeyFox, somehow


#8

Yes, STRG (Steuerung) is similar to CTRL (Control).
If KeePass is opened, KEE-2.x recognizes this and offers password substitution…

But KeePass must be opened before passwords can be used in FF, switch to desktop necessary, double work…

In older version KeeFox STRG + Shift + 2 gets KeePass login dialog inside FF…


#9

I understand what you mean. Unfortunately the new Firefox does not allow this behaviour anymore. Maybe try loading KeePass when Windows starts and leave it running (with the database locked for security of course)?


#10

I belive that in Linux problem is that in new version of Kee 2.0.0.25, there is no more setting for manual entering KeePass path, so You have to manualy start KeePass. Can please Luckyrat fix that ?


#11

Same issue @bmatic. Firefox doesn’t let us do that anymore - it’s nothing to do with Linux just that Firefox is no longer allowed to launch other programs on your computer.

This is described in Kee 2.0 features so you might want to read about the other feature changes described in that post.


#12

Thank You @luckyrat for the explanation. Time will show is that a good decision on the Mozzila Firefox side.


#13

Same behaviour: You must switch to KeePass for getting the login dialogue and accessing the passwords. …


#14

I’m running Firefox v57.0 and Kee 2.0. when I first installed Kee it all worked ok.

I initially had the same red OFF when I started FF with KeePass already running.

I’ve just discovered that if I close KeePass & restart it while FF is running, then Kee recognises it and starts properly.

Annoying, but not the end of the world.

Mike


#15

I’m also looking for the “unlock keepassDB”/“connect to keepass” from kee, I use this all the time. Also the big OFF logo is really big and it was visually less intrusive in the old version as I’m pretty sure most people don’t have keepass unlocked all the time and just when needed as a good practice so just a reduction of the OFF logo on top of it would be appreciated, about half the size would be more than enough or at least an option to customize this icon.


#16

The OFF icon style is discussed in Obtrusive icon when OFF


#17

On a Win 8.1 laptop I’m fighting the same problem (Firefox quantum 59.0.2 (64-Bit); KeePas (2.38); Kee (2.0).
Kee shows OFF grafik but in it’s menu
grafik
Kee is still offering to create a new password and saves it :astonished: in the DB, which is open.

I tried to deinstall and to reinstall the plugins for KeePass (KeePassRPC) and Firefox (Kee), but no success!

Now, sometimes and not for sure reproducable, it happens, that the OFF disapears, when I open another (second) database within KeePass. But Kee does not find any entries, if a search for Matching logins, even though there are such in both opened DB. Just now, as I retried again, Kee stillpretends to be “OFF”, but it finds matching entries from both DB… I thought. When checking this again, Kee again behavied different. My conclusion: It is unpredicatable, how Kee behavious regarding the connection to KeePass.
@luckrat: Please work on a fix. Kee is essential to work with Keepass seamless.