[Solved] Kee enters field reference ID instead of referred information


#1

While I don’t use field references often, I just noticed that on attempting to log in to a site, the auto-entered password was the full {REF:P@I:###########################} rather than the actual password. I don’t remember having this issue before. It’s possible this is related to me using keepass via mono (though that seems unlikely), and it’s possible I just haven’t checked this since it was still KeeFox. At the moment I can’t access a windows system to test there. If anyone has any insight, I’d love to hear it.

Kee 2.3.19.1, KeepassRPC 2.8, Keepass 2.38, Linux Mint, Mono 5.10.1.47

Solution: Enable placeholder access for the referred field in the entry’s settings.


#2

Same problem here. Solution I now know of (for the entire database) is described in post Placeholder handling


#3

I’ve added the instructions for enabling individual form fields now to Placeholder handling

This change (and the link to the documentation that includes the reasoning and instructions) are explained in the release notes that are on the download page for version 1.8.


#4

Ahh… interesting. I hadn’t even considered that the changed functionality could be related to the introduction of placeholders. Thanks for the info.


#5

I’m hunting around, anyone know a way to easily identify all the accounts that use a placeholder? I’m not sure I really understand the security risk here, and going through each account to find ones that use placeholders, and then allowing will be an awful chore…


#6

It’s not perfect but I have added a “Finding entries that contain placeholders” section in the Placeholder documentation that describes the only approach I can think of at the moment.