Resolved: Warning: "The plugin cannot be loaded. A newer KeePass version is required to open this file."


#1

KeePass and KeeFox stopped speaking to each other months ago. I’m running Kee 2.0.0.25 on Firefox 57.0.1 and KeePass 2.32 on Ubuntu Linux. And I solved the problem (mostly), but since I always start by searching for the error message I’m looking at, I wanted to note the solution here.

When I open KeePass I get a warning: “The plugin cannot be loaded. A newer KeePass version is required to open this file.” – I can still open my password manager, but it isn’t connected to my browser, and the Kee icon says “OFF” in big red letters.

So I started at Help and support and walked through the preferred steps there.

  • It used to be possible to get back to the Getting Started Tutorial (as recommended) but I no longer see a way to do that in Kee.
  • I looked at through the manual, found https://github.com/kee-org/KeeFox/wiki/en-|-Installation-|-Linux and realized that I need to force an update to 2.34, by following the instructions there (installing a different PPA).

It seems to be working now, with KeePass 2.37. So if you’re on Linux and getting errors about not being able to load KeePassRPC.plgx because “The plugin cannot be loaded.” and “A newer KeePass version is required to open this file.” this should help.


#2

Since the whole point of keepass/kee is security, how do I know that the PPA’s documented in the write-up are safe? Neither seems to have been made by their respective original authors. Shouldn’t it be possible to get the the extension, the keepass update, and the plugin directly from the source so one can feel confident about it?

Thank you,
Mark