Error "Authorise a new connection", pop-up is empty and comes every second new

Hello,
I installed Kee.
Unfortunately, every second I get a new pop-up window without any controls.
An “Authorise a new connection” is not possible.

What can I do?

Greetings and thanks in advance
eneo99

Operating System LMDE 2 Cinnamon 64-bit
Cinnamon version 3.4.6
Firefox Quantum 57.0 (64-bit)

1 Like

Is Cinnamon the name of a Linux distro?

What version of Kee are you using?

We’d probably need to look into browser console logs to diagnose this further but it’s fairly likely that it’s a Mono, Firefox or Operating System / window manager bug.

Hello,
thanks for your answer.

Is Cinnamon the name of a Linux distro?
No, Cinnamon is a desktop environment based on GNOME 3.
I use the distro: Linux Mint Debian Edition (LMDE 2.0)

What version of Kee are you using?
2.0.0.25

We’d probably need to look into browser console logs to diagnose this further but it’s fairly likely that it’s a Mono, Firefox or Operating System / window manager bug.

I have Firefox started
then I have Ctrl+Shift+A
then I have Ctrl+Shift+K
then I have Kee Add-ons enabled
Error occurs
then I have Kee add-on disabled
then I have Screenshot created

Thank you for your help

1 Like

I had the same problem. I think it was triggered by a mismatch of security levels.
With me, Kee got updated to v2 before I updated firefox to 57. It then asked to a new connection and I entered the connection code. I also set the security level to “high” in the connection window in Kee. But keepass wasn’t working properly, I thought it might be because of the firefox v56, so I updated firefox.
Now, keepass says “kee has rejected the connection to the server because of a insufficient security level. You need to restart the connection process to change the level.” at the little icon next to the search bar and keeps popping up the empty connection windows.

Here’s what I dit to solve it: in Keepass, I went to Tools => KeePassRPC Settings => “Connection security” and set both levels to high. Then, I could enter the connection code from a new, working popup. In the connection dialog of Kee in Firefox I then set the level to “medium” and also changed the setting back to medium in KeePass=>KeePassRPC Settings.

2 Likes