AWS login mask: Auto-submit even if auto submit is set to never in entry

#1

Hi, for some weeks, I cannot login with auto-submit to AWS anymore. I get an invalid request error. So I want to disable auto-submit just for this entry, because with manual press of the login button, it works. But I can only change this for all entries. The per-entry setting is not respected. Any suggestions?

Here a more detailed description of how to reproduce this:

Add a keepass entry with test@example.org and some arbitrary password.
Edit entry and set the following:
URL: https:// signin. aws.amazon .com/console (no spaces)
Kee: General: Auto-Fill (and Auto-Submit): never
URLS: Match-Type Domain
Form Fields: image

Then open Firefox with Kee plugin. Configure the plugin:
Filling Entries: When Kee chooses … : Do nothing.
When you choose … : Fill in and submit the form

Then open http://console.aws.amazon.com/ and you will be redirected to the login page. If you a page with only one input field, enter a number like 88888888 to see the actual input mask that is not working.
Select the kee entry.

Actual behaviour: The values are submitted.
Expected behaviour: The values are only filled in.

#2

I suspect you’re wanting this: Change the way per-entry submission options behave?

The beta containing the relevant changes should be released early next week so give it a try then to see if this helps.