Autofill not working on Xiaomi Android phone


I understand that auto fill of the credentials fields does not work on the Android smartphone. Nevertheless, the message “auto-fill by Keevault” appears when selecting either the username or password field. Is this normal ?

The offer to save by Keevault, the credentials, also appears after the username field and the password field have been filled in manually on the Android smartphone, but it doesn’t seem to be working. Is this normal ? Surprisingly the message offering to save in KeeVault IS in french !

Thanks for your assistance,

By this, I am not referring to the autofilling of usernames and passwords - that is a supported feature. So it is expected that you will see the option to autofill a username or password using Kee Vault.

I suspect that Google is automatically translating some parts of their interface (such as the request to send the credentials to Kee Vault for saving) into your device’s language, which I assume is French. However, Kee Vault 2 itself is not available in any language other than English.

If you try to save some new credentials to your Kee Vault using this feature and it does not work, please provide some more information about how we could reproduce the problem since it is expected to work, although a lot is out of our control so it definitely can’t work for every single app or website.

I am getting confused.

I don’t remember where, but I thought I had read somewhere that on Android it was not possible to auto-fill username and password fields.

So let’s be as clear as possible : auto-fill of username and password fields by KeeVault should work on my Android smartphone.

But it does not work on my smartphone with Android; I do have an invitation to let KeeVault fill-in the fields, but when I click on the invitation nothing happens. Therefore, I keep on copying each field content in KeeVault and then pasting the field content in the field.

Whereas autofilling of username and password does work on my PC with windows and chrome as internet navigator.

Let’s clarify this point first, before getting a step further to have Keevault saving automatically a new set of username and password.

Thanks for your further assistance.

Yes, it should work and it sounds like you have already enabled it. See Android auto-fill

If that doesn’t help, please provide more details about your phone and what web site, browser or app you are unable to autofill into.

I would like to enclose images of my screen to provide some details, but I cannot find the way to enclose an image herein.

Help me please.

Thanks for your patience and understanding.

Let me provide some details just manually, on one exemple.

My smartphone is a Xiaomi rednote 7.

The credentials I am trying to have autofilled by KeeVault are for acces to a local server application, the URL of which is :

What information should be set in the “integration settings” of the corresponding entry?

Do you need more information ?


You should be able to just paste an image from your clipboard into a post here. Or use the “Upload” button while writing your message. To be fair, I’ve only ever tried this on a PC so perhaps the steps are slightly different if you’re using your phone.

Make sure that you’ve not disabled the ability for the entry to show in mobile apps and browsers. Other than that, for a website, it shouldn’t really matter what you include in the “integration settings”, unless you want to make it match more than one website.

The main thing is to make sure that the URL field of the entry is correct - in this case.

Which web browser and version are you using to load this URL?

What version of Android does your phone run?

Sometimes there can be an “autofill” option in the context menu (from long-pressing on the username or password text field). If that’s the case, it would be interesting if clicking on that causes any different behaviour to clicking on the button that automatically appears when you load the web page.

I appreciate you want to get the existing entry working first which is fine, but if there is also a problem saving a new password for this website and browser combination, it could ultimately be due to exactly the same cause so bear that in mind while testing.

Please find herein some more details about my smartphone, android, and the navigator I use.

Next is a screenshot of the entry considered here :

One point I may add : when I am proposed to autofill the username with keevault, if I klick a “long” time on the username field, the username to fill appears, and if I click on the username, it is filled in the field. That seems fine.

But when I do the same on the password field, after I have been proposed to autofill the password field with keevault, the password does not appear, even in a hidden mode. The field remains blank and void.

One more thing : the behavior I just described in my previous message is specific to accessing to the URL

When I try to access to some other web site for which an entry in my KeeVault exists, clicking on the username field when the autofill invitation appears does not result in the username being filled in.

Concerning my keevault version on the smartphone :

and some recently logged information :

Thanks for your patience with the beginner I am.

Thanks for all the useful information.

I have been researching this problem and think I have found a solution for you. It sounds as though Xiaomi and Redmi require you to perform some extra steps for AutoFill to work on their phones.

Without such a device in front of me I can’t be certain about the necessary steps but hopefully you can try the below and let me know if it works or if any steps need clarification.

  1. Open your device settings
  2. Click through the menus: Apps > Manage apps > Kee Vault > Other permissions
  3. Enable the “Display pop-up windows while running in the background” setting

Please now see if the autofill menu allows you to authenticate with Kee Vault and get your credentials filled into the login form fields.

If it’s still not working, I have also found some references to an MIUI feature called “Autostart” - you might need to search for that (I think it is the name of a permission but might not be found in the same place as the “Other permissions” above) and make sure that Kee Vault is selected. Judging just from the name, it’s possible that this is needed to ensure that you can start Autofilling as soon as you start your phone, before explicitly opening the Kee Vault app.

Many thanks for your help.

Indeed you have found the solution.

I am very grateful for both your expertise and your patience.

I suppose I am not the only one you have to take care of…

Thanks again.

I have now updated the Android auto-fill documentation to include the specific information about Xiaomi that worked for your device.

It’s helpful for us to get feedback and troubleshoot problems so that we can improve the app or documentation and therefore make it easier to use for everyone in future.

Hi, I think I have the same issue with my device

  • ANY-LX1
  • Android 13
  • Magis OS version 7.1

Using Firefox 116 or Chrome 115

Kee Vault 1.0.18 / Build 42
No Error in KeeVault Log Console
Filtering the logs with I found
=> Got result for getAutofillMetadata null (Null)

I’ve check the background authorization for the app, but it looks good.

Is Honor another Xiaomi/Redmi brand?

Have you followed all the steps in Android auto-fill including trying those for Xiaomi and Redmi?

Can anyone else confirm that Honor devices need some additional setup?

I have done a lot of research online today and can find no clues what to suggest for this brand of device. There seems to be very little information about them and only passing mentions of autofill functionality so I’m not sure where to look next. One would hope the lack of information indicates their devices work just like a stock Android device but your trouble getting this to work suggests that is not the case :frowning:

Is there a manufacturer support forum where you can ask for more information about what is needed to make Autofill work on their phones?

Update : it works now, My assumption is of the last Operating System update improved the behavior. Happy to have it work nicely now :slight_smile:

2 posts were split to a new topic: Autofill stopped working when I got a new Android phone