Vault - open with tags in Firefox

debug
#1

Yesterday I created my Kee Vault account. Today I attempted to access but I get the message “offline”. After some attempts, I opened my Kee Vault but shows tags and the values. When I click in any position I go back to login page.
Please, help. If necessary, delete all my Vault.

#2

Sorry to hear that @Eng_Dark_Rose_Alchem.

I’m not entirely sure what you mean by it showing the tags and the values. If you’re sure it wouldn’t contain any sensitive information, you could post a screenshot here to help me understand.

It would be best if we can work out what’s gone wrong so that it doesn’t happen again but in case you need to reset your vault, you can do this using the reset password feature at https://keevault.pm/#dest=resetPassword

Before you jump straight into that though, it would be worth trying to load your Vault from another web browser or device. If this works properly then we can try to work out what’s gone wrong with your first browser/device and can probably fix it up pretty quickly.

#3

Thanks for the private message @Eng_Dark_Rose_Alchem. I think this indicates that the contents of the database are being displayed to you as part of an error message on screen. I will investigate what sort of problems can cause this to occur but in the mean time, you may be able to find the complete error message by pressing Enter or escape on your keyboard and then click the “Show app logs” button in the General Settings of the app (try pressing Ctrl + , (comma) if the interface has broken to the point where you can’t click the settings cog).

Also let me know how you get on with trying from a different device.

Did you create this Vault from scratch or import an existing KeePass database (.kdbx file)?

#4

So from what I understand, you imported from LastPass and something went wrong when you next tried to sign in but you have now created a new account with a different email address and everything is working but you have not imported any existing passwords to that new account?

Without information about what the error was when you tried to sign in, it’s hard to be certain of what sort of problem you might be experiencing but we can make an educated guess. Given the error message you are seeing in Chrome (“FileCorrupt: bad xml”) a problem with the import from LastPass would be my first guess. Other possibilities could be a bug in your web browser, operating system or hardware but they are all far less likely than a bug somewhere in the way Kee Vault is understanding the specific data in your LastPass account.

I will explore the relevant parts of the Kee Vault code this week in case I can spot where this type of error could be introduced, with the hope of releasing an update that can be more tolerant of invalid data from LastPass.

PS: Please don’t reply to the “noreply” email address - I’m only seeing these messages at all while I confirm that various technical systems are working as expected and the information doesn’t make it to this forum to allow others to help or follow the discussion. It may be some time before I see replies that are sent to that email address and I will disable it entirely soon. For the initial screenshot of the XML data, you would have been able to send me a private message to keep your usernames out of public view.

#5

I have managed to create a test LastPass export containing bad data and can now reproduce the problem you’ve described.

I’ll continue working on it so that at the very least we can throw away the bad data before it makes it into Kee Vault after starting a new import. I’ll look into whether it is possible to recover your existing Kee Vault data too.

I’ll let you know when I’ve made more progress.

#6

I’ve just pushed out a new version of Kee Vault which will ignore the invalid data being supplied by LastPass (and any other password managers that do this).

Since this appears to be the most likely explanation for the problems you’ve had @Eng_Dark_Rose_Alchem you should find that importing now works correctly in Kee Vault version 0.9.8.

If you can sign in to your Kee Vault, you can click the Import button to start a fresh import from LastPass.

If you can’t sign in due to the error about bad data, you will need to reset your Vault as mentioned earlier - you can do this using the reset password feature at https://keevault.pm/#dest=resetPassword

I am investigating whether we can develop a way to automatically recover from this particular type of damage to a Vault but it will require collaboration with other developers, some careful planning and therefore probably too much time for it to be sensible for you to delay the account reset any longer.

Given what you’ve said before, I suspect it’s unlikely that you had any opportunity to store vital information into your Vault before it started giving you this error. If I’m incorrect about this then please do let me know and I can schedule some time to develop a tool that will allow you to manually repair the damage.

Finally, I would like to thank you for your patience and help identifying this problem by extending your free trial period so please send me a private message on this forum confirming which email address you have used for your Kee Vault sign in.