Using KeePassRPC on WTS?


#1

We want to use KeePass and the browser addon Kee on a Windows Terminal Server, but it doesn´t work.
Apparently the problem is the port 12546 of KeePassRPC, which can only be used once at a time.
I try to use different port for different user, but only 12546 works.

Is there any solution to work with Kee and multiple users?


#2

You’ll have to change the port in KeePass and Kee.


#3

Thanks @YannickSchinko for your reply, but I already tried this.
All user have an “own” port number, which is entered in KeePass and Kee.

One user have a connection between KeePass and Kee. At all the others Kee asks after a connection password, but KeePass doesn’t deliver it.


#4

Does WTS force the same Firefox user profile on all users? If so, it might be overwriting the change you make for each user. Or perhaps it prevents write access to either the Firefox profile or KeePass configuration file? I don’t know much about WTS I’m afraid so I’m not sure what else to suggest beyond these generic ideas.


#5

Sorry for the delay of my reply.
You can compare the terminal server with a desktop PC which is used by several users at the same time.
So each user has his own files (C:\Users\USERNAME\AppData\Roaming…) and from there each one his own Firefox user profile. So I don´t believe that something will be overwrited.

What about the port of KeePassRPC? Is it allowed to use other port numbers then 12546?


#6

I can answer it for my own: it´s not allowed :disappointed:
Here’s what I’ve been trying to do:

I have two user working at the terminal server. The first one has running KeePass and Firefox with the Kee plugin normally (default settings).

Then the second user starts KeePass (also default settings in the KeePassRPC Options) and for the first time Firefox with the activated Kee plugin. The browser opens the Kee Authentification tap and in the same time you will get a second window from KeePass with the keyword. Nothing new – you know that.

Now I change the port RPC Options e.g. to 12540 and do the same in the Kee settings. After that the Kee Authentification tap opens again, but there is no keyword window from KeePass.

Maybe this will help narrow down the problem…


#7

Did you restart KeePass after reconfiguring the port?

I can’t recall if that’s necessary or not but always worth a try.

Otherwise, I’m not sure what to suggest next - changing the port is allowed and works on a standard multi-user desktop so I’m not sure what funky stuff WTS could do to block or override the configured ports.