UN/PW fields do not populate with v1.80 and v2.39 in FireFox


#1

When 1.80 came out I updated it in my (then) current KeePass 2.38 and Firefox 59.0.3. Un/Pw fields stopped populating immediately after. I rolled back to prior version of RPC and everything was fine again.

Updated this morning to KeePass 2.39 and it immediately screamed about RPC and demanded 1.80 (verified it does not work with Firefox 59 unless I updated to 1.80 anymore). However, now I’m back to the un/pw fields not populating again.


#2

Please make sure you’ve read the release notes first. If nothing there helps, please provide more information about what exactly you do and what behaviour has changed (and from which version of KeePassRPC you upgraded). Many people use the same combination of software versions as you without any problems so unfortunately “UN/PW fields do not populate” is not enough on its own to offer any specific advice on your situation.


#3

Binary logins do not populate as they did with the previous version. I cannot find a version number in the version I was using but it was the latest prior to 1.80. Unfortunately, this support portal won’t let me upload it to you.

Steps to reproduce:

Open KeePass 2.39 (loads automatically at Windows start-up)
Open Firefox Quantum v 59.0.3
Open website using binary username/password fields - at this point fields would normally populate and site would allow access. On v1.8.0 I receive the attached request for credentials (binary.png) binary

Further discovered this morning:
Open second website that utilizes the password reference field capabilites - the password field is not populated with the referenced password but is populated with the reference ID instead.

Check release notes for any oddities to how I updated. None noted.
Downloaded new version
Backed up old version
Pasted new version into Plugins folder
Closed and restarted KeePass 2.39

Hope this helps.


#4

The release notes explain the improvements to placeholder support and link to the new documentation regarding how to use these in 1.8+

Placeholders

It seems likely that you have a placeholder in your login for the first website so when that login fails, Kee falls back to displaying the manual HTTP Auth box that you have pictured.


#5

Will take a look at this today. Thanks!


#6

This has resolved the issue - many thanks.

I skimmed past the “Placeholders” topic as that didn’t register with me as “Field Reference”.

All is performing as expected now.


#7

That’s good to hear.

I’ve now put a note on the Placeholders section in the release notes in case anyone else expects the terminology to be “field reference” too - I suspect that is one of the most commonly used types of placeholder.