Top Folder displays all entries

My top folder (default label “My Kee Vault”) contains the subfolders. Just like in Keepass.
In Keepass I see only all uncategorized (ungrouped) Items, just how it should be.
In Keevault I see all entries in the top folder. No difference to “All Entries”.
Do I miss an option?

There’s an option in “General Settings” called “Show entries from all subgroups” which you could disable.

That did it, thank you!