Sync error : [object event]


I tried to save my .kbdx onto Kee Vault but it keeps boucing off with this Sync error : [object event] wich in itself isn’t that helpful.

Thanks for help.


What device / web browser are you using when you see this error?

It sounds like you mean that this error is occurring when you try to save a newly imported kdbx file. Is that right? Did you manage to save it at any point in the past?

There should be more information in the logs when it happens.

Viewing application logs

  1. Click on the settings icon (cog) in the footer
  2. Scroll down the “General” settings page to the “Advanced” section
  3. Click on “Show app logs”
  4. If you want, you can select the logs with your mouse and copy them to the clipboard

If there’s still nothing of use there, even more information should be available in the browser console. If you’re not sure how to access that, I’ll try to come up with a guide soon.

I’m using FF quantum 66.0.1
Also yea it’s for a newly imported file, didn’t managed to save at any point, ever.

It also looks it doesn’t let me c/c to clipboard when in kee vault.
So here’s a screenshot, hope it helps …

Yeah that helps.

It looks like we can’t open indexedDB for some reason. My best guess is that this is due to a long-standing Firefox bug that prevents access to local storage when running in a private browsing window ( Are you using a private browsing window? Does Kee Vault work if you use a non-private window?

Or can you think of anything you have configured or any add-ons you have enabled that might cause Kee Vault to be unable to access this type of local storage?

indexedDB is required for offline support and I’ve not really made any effort to make such support an optional part of Kee Vault so I’ll need to do some more research on this topic. At the very least I’ll need to improve the error message!

Well, i only use FF in private mode for cookies reason & such.
I tried to log in on microsoft Edge but it keeps spinning in loading status.

On FF i’m using Ublock Origin, Privacy Badger, Https everywhere & Decentraleyes, also CSS Exfil Protection so … nothing at my humble opinion that would really make access impossible to local storage.

In private browsing mode you should be seeing a message at the top of the page like this:

“Offline access is not available on this device. This is expected when in private browsing mode. If you use Firefox 60 ESR you will need to manually enable “Service workers” to enable offline support.”

Can you confirm if you see this or not?

It talks about service workers but this indexedDB problem is quite related according to the Firefox bug I mentioned earlier. I’ll try to come up with a plan in the next few days to improve this.

I’ll also take a look at Edge when I next get access to a Windows machine - it sounds like there’s a bug I need to fix soon.

Yes, this message does show up.
I still can import said database, but just can’t save it.

I’m still trying to get Kee Vault working in Edge - there are loads of important security features that browser does not support but hopefully I can workaround its limitations soon.

The private browsing problem is complex. I’ve documented the basics now and will try to see if there is some way I can at least include a warning in the app in the coming weeks but I can’t promise anything.

I still can import said database, but just can’t save it.

Really, this is the thing that most concerns me. It’s fundamentally impossible to save data when in private browsing mode because that mode is explicitly designed to prevent that from working but I would like to find some way to ensure that this is made clearer much, much earlier. It’s a terrible experience to go through the registration and import process only to find that your work can’t be saved. Hopefully you didn’t spend much time editing the imported data before you found the problem but it is certainly feasible that someone could spend hours on this and then get told NO! This greatly upsets me so I’ll be prioritising finding some way or another to reduce the chances of this happening.

No, i didn’t spend time modifying in here, i know how works alpha/beta version of things so i’m always cautious about those thingy things ;D

It’s better i tell about this now rather than later i guess, for your sake at least.

Yeah, definitely good to be able to work through these issues sooner rather than later. I’m glad you were cautious!

I’ve released an update so that Kee Vault works on Edge now - it’s slower than other browsers because it lacks many modern features but it seems to work at least well enough to enable access from machines where that’s the only browser option.

I’ve made a plan to improve the behaviour relating to private browsing. This week I’ll try to improve the saving behaviour so that it can still save to the Kee Vault cloud even when local storage throws an error like the one you saw. In future, I’ll develop a way to warn private browsing users that they don’t have a copy of their Vault saved on their local machine -

I guess since i’m the first having this problem, it’s not that much of a problem for rest of users ?

But when uploaded to kee vault, does it modify also the version on desktop or i’m being a bit dumb ?

The “Import” of an existing kdbx file from your desktop is a one-time operation and no modifications are made to your desktop version.

You can “Export” a new kdbx file from Kee Vault if needed but Kee Vault is a separate program from KeePass on desktop so no ongoing synchronisation is possible.

It sounds like this behaviour is not what you expected?

If so, any thoughts on what could have made this clearer for you?

As for being the first having a problem, I’ve only enabled access for a small number of people so far - once more than the current 50 people are using the service, we may well find others in the same situation.

No that’s just what i thought but i asked to be sure :slight_smile:

I know that it just stay in the vault & need to be exported to have said version on your desktop.

But i still ask myself if i want to use this service or disable my private settings for FF >.<

I tend to use extensions to block trackers, ads, etc. rather than Private browsing but I know that’s not quite the same. Maybe there is a way to add an exception for specific websites? I did a quick google for that - nothing obvious came up but it wasn’t a thorough search.

I tend to use both, private browser & add ons at same time sooo yea, can be a really bother to work around it as a dev.

And from what i’ve seen, it’s either on or off kinda option, not a thing you can disable for one website sadly.

But i doubt i’m the only one using this setup & i’m not gonna lie when i said it’s a bit off-putting as it is right now, particulary if it’s a paid service ^^"

I’ve released the fix so that saving (and loading) to the Kee Vault cloud works in private windows. Please let me know how that works for you now.

I’ve also done a bit more reading around the broader subject and thought that this alternative approach to using Private Windows looks interesting:

Probably too many performance issues to be practical for me personally in the short term (100+ active tabs/containers and the permanent 5MB disk space leak per new tab puts me off trying it out at the moment) but I’ll be keeping an eye on it and I’d be interested to hear if anyone else placing smaller demands on Firefox finds it works well for them.

Well, i just tried & your magic worked just fine, thanks KeeVault Voodoo leader :partying_face:

I’m going to check this alternative approach too but maybe… maybeee having 100+ actives tabs at all time isn’t the best way to go either :sweat_smile:

Edit : Ok, i just tried those containers things & i remembered why i wasn’t using it…
I spend 10 minutes not having a clue why it wouldn’t work with my private mode then spend another 10 min figuring out how to turn off permanent private mode & then it made everything else explode in my FF, couldn’t open a thing, not even Kee Vault, it just keep loading when i tried to fill in my mail.
Edit² : Also good job not making Kee Vault explodes when using dark reader add-on :smiley:

1 Like

3 posts were split to a new topic: Sync question