[solved] Keepass not generating authorizatioin password for kee authorization


#1

Something new maybe with latest updates but both kee extensions(chrome/FF) are not properly connecting to keepass. My database is open but the extension thinks not further keepass is not being prompted to generate a authorization password so there is no way to get the extension connected. I have emptied the plugin cache, revoked any authorizations and restarted both keepass and the browsers but the issue persists. I did get it to eventually work yesterday but today when I boot up the issue is back. Still running rpc 1.7 which I think is still the latest and 2.3.19.1 of the FF extension and whatever beta of chrome extension you have the webstore. This on windows 10

Kee was not allowed to connect, probably because you entered the connection password incorrectly. Please type in the new password when prompted.
Help Centre
Options
You are not logged in to your password database. Launch KeePass to enable Kee

also seeing this in the options of extension

NB: change the setting in KeePass.config or else Kee will not always be able to communicate with KeePass

#2

Well turns out nothing to do with Kee (maybe) but if in windows you have another user logged in and with their keepass database open then you get the behavior above. Maybe windows doesn’t run each instance of keepass as a separate process and thus kee is unable to find the open database (running instance/process).

This is not the expected behavior and I’m not sure if there is anything the rpc plugin and kee can do about it?? I’m normally running keepass/kee on a linux box so not surprising that windoze creates this issue.


#3

See Multiple User Settings for more information about running KeePass on the same machine for multiple users.