[solved] Kee don't follow references


#1

If the username or password on Keepass is a reference to other entry, Kee doesn’t get the user/pass it references, instead getting {REF:U@I:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX}.


#2

Hello,

you have to enable the Keepass placeholders for Kee :


#3

Damn ! I Just downgrade my KeePass2 and Kee installation to be able to use again the references. And now I found that post.

For the record, I’m on Ubuntu Xenial and downgrade to:


#4

Hi there,

I encountered the same issue today after upgrading this morning. Do you have to do it for each entries ???

B.


#5

I suffer from the same issue. How is it possible to change “Database default”? I tried to search for a corresponding option that will affect all database entries, but I couldn’t find any.


#6

File > Database Settings > Kee > KeePass Placeholders

:wink:


#7

While you definitely -can- enable placeholders by default on your database, if you have anything short of hundreds in use, for security reasons it’s a much better idea to search your database for references in use and toggle each one. If you want to take that route, rather than using the search bar in the keepass2 window, hit ctrl+F to bring up the detailed Find window, toggle each field you want to search (potentially including passwords and other fields if necessary for your database), and just enter {REF as your search string. You’ll get a concise list to change the setting on.

Theoretically a KPScript or a plugin could be made to allow batch placeholder toggling (via the selected entries right click menu for instance), but I don’t personally have the requisite familiarity with Keepass or specific programming knowledge to accomplish this.