Matched login entries less accurate in Kee 2.0?


Since I update to Kee 2.0, the matching seems less accurate.
Frequently the login is not filled and the list of “Matched login entries” is very big !

I don’t understand because the URL is set in my keepass entries so the match should be easy. Moreover it used to work very well before.

Is there a known issue about that ?


Yes, I am experiencing this same issue. Problem seems to be that Kee is matching by domain, and so it “matches” all the credentials in the KeePass safe with that same domain. If you edit a specific credential you will see a tab to the far-right called “Kee”, then select the tab “URL’s” and in there you can select something more sane like “Hostname”. The problem is that this setting doesn’t seem to affect any other credentials (KeePass Entry) so you have to change this in every credential, which is nuts.

Could it be possible to have a global setting to manage this behaviour ?

This behaviour shouldn’t have changed for a couple of years or more. Domain matching rather than hostname matching has been the default for many versions of KeeFox. Maybe you have some specific examples of domains where the behaviour has changed from v 1.7.3 to v2?

There has been some discussion over the years about maybe adding a feature to set a default value but it’s never been a serious enough issue for anyone to really take on the challenge of ironing out how it would work and doing the implementation work to deliver the change.

Feel free to take it on if it’s something you’re interested in seeing changed.

Unfortunatly I have no development skills :slight_smile:

I use Keepass in a professional context so I use every day many many webapps sharing the same domain (i.e. * ) !
I assume that I will have to update all my keepass entries one by one :confused:

Thank you for your quick answer.

We have been using KeePass and Keefox for about 3 years now in both Firefox and Thunderbird, and I have never seen this behavior. Essentially if we have the following URLs:

Kee will “match” all the credentials (KeePass Entry’s) from all open databases that have ‘’ in the URL field, completely disregarding the ‘host1’, 'host2, ‘host3’ parts of the URL’s.

We are using both Kee and Keefox presently in-house, and only people with Kee are experiencing the issue, and I have tested it out myself in both Linux and Windows.
As for ‘adding a feature to set a default value’ - Well there already is this setting but it’s only available in and for each individual KeePass Entry, which when one has hundreds of credentials (think multiple DB servers with dozens of user accounts) it’s a nightmare to have to change it from Domain to Hostname.

Here is a screenshot of the settings which, I think, should be made globally effective.

Which version of KeeFox is treating each host on as different?

The only thing I’m aware of changing between KeeFox and Kee in this area is the source of information about what counts as a domain name vs a hostname… I’d only expect a difference with exceptionally rare TLDs though (not .com, .net, etc.)