KeeVault keeps logging itself out in Chrome

KeeVault keeps logging itself out in Chrome.
This is new behavior for me. It used to stay logged in until I closed the browser.

I never had this issue on the standard Chrome but happened when using Chrome Canary.
Disabling discarding tabs fixed it chrome://flags/#proactive-tab-freeze-and-discard

A bit more information about this Chrome “experiment”

Also, you could check the auto lock settings under your Kee Vault General settings

Proactive Tab Freeze and Discard is on Default status and I haven’t ever touched it.
I checked the Auto-Lock settings in KeeVault and it was set to 15 minutes, but I never changed this and on my work laptop it doesn’t auto-lock ever. Is this setting different on different PC’s? I set it now to ‘Don’t auto-lock’.

Thanks for reporting the issue @eab and thanks for the advice @blgo.

I’ve also not been able to replicate the “tab freeze / discard” problem on Chrome Canary (no matter how I configure those flags) but it is a very non-deterministic behaviour, so even if/when they enable the behaviour on all browsers I think we just have to hope that Google adds the domain to the mystery “whitelist” feature that the control panel implies will ensure Kee Vault is not aggressively deleted by Chrome.

The “Inactive auto lock” setting is shared across all devices you sign into. The default setting can be “never” or “15 minutes”, depending upon some details of how and when you first signed up to Kee Vault but once you’ve saved your vault and then signed in on another device, the 2nd device will receive whatever setting was selected (or defaulted to) on the 1st device so one would not expect the setting to spontaneously change after a long time.

There’s one thing that could be a little different with this setting compared to all the others that are synchronised along with it: If a form filling extension like Kee or in-built browser behaviour adds a value to the invisible (essentially unused) email address form field on the Kee Vault landing page and you select the “existing users: Sign-in” link on that page, the timeout will be set to 15 minutes. Even on the off-chance that this is exactly what is happening in your situation, I don’t see why the setting would not simply be updated to the most recent setting you saved on other devices as soon as you have signed in to your Kee Vault. Still, if the problem keeps occurring this may give us somewhere to start a more lengthy investigation into the cause.

Let’s see if this keeps happening and/or happens to other people and then prioritise further investigation as needed.