KeePass + Kee + ING Diba online banking login page?

compatibility
#1

It seems that Kee (as my extension for Firefox) can no longer identify the ING Diba login page, as a result I have to revert to do an autofill from KeePass instead of picking my login from the page itself.
I’ve tried to define an exception from within key but I can’t get it to work.

Has anybody been able to convince that page to cooperate with Kee?

Cheers,
Olaf

P.S.: I might have to add that I’m using the German Diba site.

(X’posted from the KeePass forum)

#2

I was able to solve the problem by adding two additional URLs to Kee.

That is, my KeePass entry’s URL is set to https://banking.ing-diba.de, so there is 3 URLs in total now.

In addition to the above URL I added the following ones for each KeePass entry (I have several accounts) on the Kee-tab/URL-tab:
https://access.ing.de
https://banking.ing.de

In all tests I’ve made so far Kee always presented the matching KeePass entries.

#3

Well, it’s broken again. This time, the Kee doesn’t fill in the account number, even though it seems to recognize the two required fields. That is, the Kee-icon will appear within both the account number and the password boxes, but if I choose an entry from the list, only the password will be filled in, the account number remains empty. Any insights/hints?

#4

What changed? Maybe the update to Kee 3.2?

If there’s content in the username field the new protection against accidental data loss will prevent it from being auto-filled. Having loaded the link in your original post though, it doesn’t look like that’s the case so perhaps something else on your system or in your entry was changed? Maybe check the KeePass entry history and see if rolling back to an earlier version makes a difference?

#5

I have the same problem since the new Kee version !
Previous version worked fine as long as I had set Kee to not automatically fill the form.
If I pressed the Kee symbol in any of the 2 fields for Username or password
it filled correctly both fields.
With the current version only the password is filled.
So I’m back to WebAutoType plugin with does fill both fields without problems.

#6

Interesting that you had overridden the form filling behaviour.

Maybe try disabling the new v3.2 option: “Editing the Auto-submit behaviour of an entry also overrides this behaviour”

If that doesn’t help, I will have to find some time to look more closely at this specific website to find more clues.

#7

No, this doesn’t help.

#8

I can’t reproduce this problem in Chrome or Firefox, using Kee 3.2.

  • I loaded https://banking.ing.de/app/obligo
  • I entered a 10 digit number in the “Zugangsnummer” field and a 4 digit number in the “Internetbanking PIN” field
  • Then clicked “Anmelden”
  • Kee detected the potential new login entry and I clicked “Save latest login”, saved the new entry in KeePass and closed the browser tab
  • Opening the site again correctly autofilled both fields, both automatically and when I manually selected the entry from the matched logins panel from clicking the Kee icon in either field.

Can you provide more detailed information about your Kee and entry configurations and more detailed steps to reproduce the issue?

1 Like
#9

Thanks for your time, @luckyrat!

The ING banking website is a bit strange in that it redirects to different pages. For this reason I’ve included the addresses I quoted in my post here.
It seems that, for whatever reason, my posts containing links were flagged as spam, so I won’t re-quote them here (hence the link to the posting further up).

Does that help at all?

#10

I end up at the same page from all of those links (after I click “Login” in the top right of one of them): https://banking.ing.de/app/login?.

Do you end up at a different login page? Perhaps we get sent to different places based upon our geographic location or some historical local data such as a cookie.

I have now also tried adding a 2nd matching entry and everything still works as expected - all combinations I can think of regarding auto and manual filling, the chosen entry and the specific Kee field icon I click on seem to work just fine.

The forum flagged your posts as spam because it thinks a relatively new user with little other posting history creating multiple links to the same website is suspicious… which does kinda make sense I guess. I’ve told it that it’s wrong this time so everything should be back to normal now (although I have no idea whether this frees you up to post exactly the same URLs again or if the same thing will happen). If you have further problems just send me a private message.

If we keep seeing this kind of spam mistake there’s no doubt some sort of advanced setting I can tweak but in the mean time I’ll just keep undoing the system’s mistakes (I only see a mistake once or twice a month at the moment).

#11

Its the same login page I get.
I have 2 logins for it and clicking the Kee icon in the username field correctly offers them.
If I then click one of this names its only fills out the password field.
For testing I removed all KeePass plugins with the exception of KeePassRPC
but the problem is still the same.

#12

Do you have any other browser extensions installed?

What browser (and version) are you using?

Do you have another browser installed that you can test with?

#13

I tested with 3 browsers:
Chrome Version 74.0.3729.169 (Official Build) (64-bit)
Chrome based Microsoft Edge Dev Build 76.0.167.1
Firefox 67.0 (64bit)
None of them works and all have only the Kee plugin for password filling installed.

#14

Maybe some further input from others will help to narrow down what can cause this problem. In the mean time, if you haven’t already, make sure you are using entries that have been saved initially using Kee 3.2 (i.e. replace your existing entries with new ones in case there is something about their configuration that is causing the problem).

I don’t know what else to suggest at this time I’m afraid.

#15

Dear all,

It seems that this is the thread in the whole internet where this subject is discussed. Has anyone found a solution for that? I have the same issue and not found a solution yet. Have also sent an email to the bank to ask for what has changed.

Marc

#16

As the KeePass plugin WebAutoType has still no problem to fill out Username and password
there was nothing changed by the Bank.
The only change was the new version of the Kee browser plugin.

#17

Hi horst, Good point. Will try WebAutoType then. Thanks Marc

#18

New Login page is changed to: https://access.ing.de/

Workaround:

  1. Login with other Credentials (123456)
  2. Save Last Login by Keevault (plugin)
  3. Correct the Credentials for the new created entry.
  4. Use this entry for the next login.
    grafik

Problem:
I have mentioned, that only the Username is not recognized for the old Entry but PW as well.
For the new crated entry (like described above) the KPRPC JSON gets the “123456” actually used to be Username", direct into this field: “name”:"view:zugangskennung:zugangskennung"
grafik

You can also solve like that:
Change mentioned values in Kee Form fields:
grafik

1 Like
#19

I fixed it for me by just adding the name “view:zugangskennung:zugangskennung”
to the existing Kee form field “KeePass username” and also the id “id5fe503d”.
No need for any new entries.
The main entry URL is https://banking.ing-diba.de/OnlineBanking/index.html
Thanks for analysing the required field values.

1 Like
#20

I’ve just tried this with my three accounts - it was enough for me to just add “view:zugangskennung:zugangskennung” to the name field.

Thank you guys!