KeePass Authorisation requested multiple times a day

Hi, I’ve used Kee within Firefox for years without issue but recently I have been asked to enter an authorisation key at least once a day; sometimes 2 or 3 times in a day (such as yesterday). The only change to my PC configuration that I am aware of is that Windows 10 updated itself a couple of weeks ago to v2004. After entering an authorisation code, I notice that the Kee icon in the Firefox toolbar has a yellow background which I thought was indicative of a new installation and I have not been re-installing it! The last install was to v2.4.5 back in May. My handful of Firefox Add-ons have not changed for years - that I am aware of - so I am stumped as to what is going on. Any ideas?

No one has replied to my request for assistance so am I alone in having this problem? It’s been a fortnight and it’s still requesting multiple authorisations a day! I downloaded the latest RPC plugin as requested overnight and that has made no difference. I’ve also tried reinstalling the main Kee Add-on for Firefox. I can see that Kee has picked up the latest version of the plugin by looking at the Tools/Plugins menu item.

PS Is there somewhere else I should be posting this to get assistance?

Have you tried following all the advice in Troubleshooting?

Thanks for getting in touch.

Yes, I have been through the Troubleshooting page.

** You have set Kee (and KeePassRPC) to the high security level *
— No, it is unchanged at Medium

** You have set a very short expiry time for the authorisation*
— No, it is unchanged at 8760 hours

** You have some other add-on or setting which prevents your web browser from saving the Kee authorisation key.*
— I use Firefox in almost its vanilla configuration and any changes are only trivial ones about Home pages and tabs. As far Add-ons, only a handful that, again, I’ve had for years eg Print Edit, enabling right click, showing passwords and Cameliser.

** Maybe some other reasons we’ve not come across yet (such as problems with your web browser or KeePass being unable to save their configuration files?)*
— Not had any problems with the browser and been able to save the plugin file to its required directory without any issue, too.

What should I try next? :slight_smile:

Are you the only user of your computer?

Do you have any file syncing programs or KeePass plugins that might be causing the KeePass configuration to be reset from time to time?

Do you use Firefox on multiple machines? Some advanced synchronisation setups can cause problems for addons.

I am the only user of my machine.

The only file-syncing program I use is Dropbox for a handful of directories but the configuration of that has not changed for years.

The only KeePass plugins listed are the KeePasRPC (v. and Web Site Advantage KeePass Firefox Importer (v. I don’t know anything about the latter although it is listed in the Plugins screen of KeePass; was this automatically installed because I use Firefox?

My wife has a separate machine (also running Win10 v2004) and she uses Firefox but there is no syncing between the two Firefoxes. However, we do both access the same password database - which is stored in a directory that is synced by Dropbox - but this is an arrangement we have had for the past two years and, again, we have made no changes to the way we use it. Significantly, she is not being constantly requested to authorise connections.

The only thing that has altered in the same sort of timeframe is my machine upgrading itself to v2004. This caused issues with viewing directories on my Synology NAS box but we eventually resolved that by using SMB3 and forbidding the NAS box to use its default SMB1. I don’t know what SMB is but it was obviously important!!!

I have the exact same issue. Kee starts to ask for a key at EACH firefox start. This is troublesome.

Been using it for years before that without a problem.

Hi LuckyRat

I have not posted again as I saw you had dropped a new release and thought you might be occupied following that up BUT I am still experiencing this problem every day. Unlike JBPlinn, it is not just when I start Firefox at the start of each day but at odd times during the day, too.

Presumably this code should be stored somewhere but is that it is not taking, is it being overwritten by some other automatic event or what? Surely if it is being rejected due to security reasons, say, then Windows would issue an error warning of some sort? I have seen no such message. Doesn’t explain why it has worked for years and only just started playing up which is why I am suspecting some change in the recent Win10 release. Mind you, my wife’s PC updated itself to the new release shortly after mine and she is experiencing no such issue!!!

Any thoughts you have: much appreciated.


I have the same issue too with Chrome, only started happening after updating to Windows 10 2004, haven’t found a solution to this yet. Was working perfectly before on Windows 10 1903.

It has no problems with Windows 10 2004.
Works here with 2 browsers at the same time
Firefox and Chrome based Edge

Hi horst, I think what you meant to say was “I have had no problems with Windows 10 2004” :slight_smile:

This might be a herring-rouge but, with v2004, I started to have a problem using Windows Explorer to directly access my Synology NAS box and it turned that Microsift had deprecated SMB v1. Switching to SMB v3 solved the issue. Now, I have no idea what SMB is, let alone the difference between the two versions, but I followed the directions of the Synology engineer to change the configuration on the NAS box and all was well again. So I wonder if there’s some subtle setting somewhere that some people have set on their PCs and others don’t that is causing this Kee issue? As I said on on earlier post, my wife’s PC that uses the same database and is also running v2004 is working just fine!

Answers on a postcard very much welcomed!

I have exactly the same Problem on two Windows 10 machines.
I think it was a Windows 10 Bug and has nothing todo with Kee or Keepass.
It happens always, if I use OpenVPN. Always during a switch between Normal an VPN-Connection comes the Authorisation Request.

Links with more informations:


I have the same issue here. Everytime I start KeePass it request Authorisation with firefox. I have the newest versions of Firefox (83.0), KeePass (2.46) and KeePassRPC ( I use the same configuration on four Windows PCs (Win 10 20H2). Only one of them has these problems.There is not automatic synchronization between the databases. From time to time I simpy coy the datatbase.

Any ideas?

I used to have the same issue with FF (78.8esr x64), KeePass (2.46) and KeePassRPC (
Switching to the latest KeePass (2.47) solved it.