Kee Vault has launched! 🚀

#1

We’re launching today! :tada: Join the Product Hunt community to save up to 50% and get a year’s service for only £10! Act fast - the discount reduces every few hours :hourglass_flowing_sand:

Check us out on Product Hunt and click through to the Kee Vault app (website) now to claim the Product Hunt community discount! We’ll tell you what discount you’ve achieved when you arrive at Kee Vault.

Visit us on Product Hunt now!

If you know anyone else that might be interested, they’d probably appreciate hearing about the Product Hunt offer while the discount level is still high?

I’ve put a post on our Facebook page: https://www.facebook.com/keevault/ and put a message on Twitter: https://twitter.com/keevault so please like, share, comment and retweet etc. as you see fit.

The current discount level and time remaining until the price goes up will be displayed at the top of the community forum and Kee website for the next couple of days. Essentially, it will drop by 5% roughly every 3 hours and end up at 20% off until the end of this week.

Existing Kee Vault users should have already seen this message with extra information relevant to them in the email that I sent out from Product Hunt.

Feel free to ask questions about the offer here or on Product Hunt but please understand I’ll struggle to respond to everything quickly enough so my advice is to just try things out if you’re not sure.

I just want to finish by saying thanks again to all of you that have supported this project so far, whether through trying out Kee Vault in recent months or by contributing your time and skills in other ways over the years. I’m really excited about what’s next for Kee Vault and the Kee browser extension! :heart:

#2

Hi,
I can open the ProductHunt web page, but every link I click on that looks like it should go to keevault seems to briefly load another page (probably keevault) and then return to the ProductHunt page. This happens in both Firefox and Chrom. IE seems to open https://keevault.pm/#couponCode=PRODHUNT, but the page doesn’t render properly.

I’m a little confused.

Brian

#3

Well that makes two of us, apart from the Internet Explorer bug - that browser is too old to work nowadays.

I can’t think of anything that could cause a redirection from Kee Vault back to Product Hunt. I suppose it’s possible you have some other extensions installed in Chrome and Firefox which might be doing something weird?

You should find that clicking on the link to the website circled in the image below:

… will send you to Kee Vault with a full-page overlay describing the discount offer:

https://ph-files.imgix.net/aef514ad-07f5-4b5e-a154-1657dc068a69?auto=format&auto=compress&codec=mozjpeg&cs=strip

As mentioned elsewhere, if you’ve been to Kee Vault before then this might not work the first time - you’ll need to update Kee Vault… but although an old version might cause this screen to not appear and the discount to not apply, I can’t see how it can cause a redirect back to Product Hunt.

I await any further clues with anticipation :slight_smile:

#4

I have a few extensions on FIrefox, which is why I tried Chrome (I keep it vanilla, and don’t use it often). When I click on tthe link you circled (which is what I was doing) I see pages open and close and then end up back where I started. In Gmail, if I copy the url behind the link you circled and paste it into a new tab it seems to work just fine - I go to the image you showed, then click through to https://keevault.pm/#. However that page won’t show me anything but login or register. I can’t actually find out what Keyvault is about from that page. It’s night time here in Oz. I’m calling it quits for the night.

#5

How does one know whether or not they have successfully claimed the discounted offer?

#6

You’ll see something like this when you load Kee Vault:

If you see that (and don’t reload in the mean time) then when you sign in it will apply to your account and you’ll get sent an email that confirms the change.

#7

Ok, well I have never seen that and I have been clicking on the “Website” button on the Product Hunt page, but it opens the keevault.pm page and then a second later it closes.

#8

There is a bug with the link on that page for some reason… don’t understand and it seems intermittent so not sure if it can be fixed.

You can probably right-click it and open in a new tab, or just re-open the tab that the browser accidentally closed (e.g. Ctrl-Shift-T)

#9

@bec So I think overnight we have established that the problem was that Product Hunt opens Kee Vault in a new tab in a way which sometimes causes the web browser to close it. We’re not sure why yet, or why it’s not reproducible for everyone, but there are a variety of workarounds, the easiest of which is to just manually open the link in a new tab (however you normally do this in your browser - long press on it, right click for some menu options, middle-click your mouse button, etc.)

Hopefully that’s the main challenge out of the way but don’t forget you might still have to update to the latest version of Kee Vault if it asks.

I’ll be off to bed myself soon and hopefully you’ll work it all out before I get up but don’t stress about the level of discount - it’s clear that you would have got the full 50% without these complications so I’m happy to adjust things in the next few days so that’s what you end up with.

@eab, as I say above, I’m off to bed in a bit but hopefully you got this to work already - if not I can try to help further tomorrow.

#10

OK, well I haven’t tried it since, but if the 50% discount is in the bag regardless then I don’t need to … as that is all I am after :smiley: