Kee stopped working in Firefox -- and in Chrome

(UPDATE: SOLUTION FOUND. See subsequent post.)

In Firefox 84.0.2 for Windows, the Kee extension stopped working for me this week, after having worked well for years, including on the same websites where it has previously worked.

Websites with KeePass entries no longer autofill, and the little “V” Kee icon no longer appears in any form fields. KeePass itself continues to work, and the KeePass hotkey works as it previously did, for some websites. The Kee extension icon still appears in the browser’s toolbar (without “OFF”), and the padlock icon in the Kee drop-down menu is still green.

None of my Kee or KeePass settings have changed. I am running Kee 3.6.27, Keepass 2.47 (although this issue also existed in 2.46, before I tried updating this morning), KeePassRPC 1.14, and Firefox 84.0.2.

Reinstalling the Kee extension did not fix the issue, nor did revoking authorization in KeeRPC and re-authorizing.

Oddly, when I autotype a stored password from KeePass, Kee pops up its “Do you want Kee to save this password?” message, even though the password is already stored in (and indeed is being autotyped by) KeePass. It’s as if Kee has become totally disconnected from KeePass, despite the toolbar icon being the normal color and the padlock icon being green.

Chrome is also affected. Odd.

1 Like


I just recalled that this happened once before, as posted here and here.

The solution then, as now, is to re-select the “Kee home group” in KeePass (right-click on a folder in the KeePass folder hierarchy > Set as Kee home group). Doing this restores the Kee extension functionality in both Firefox and Chrome, with immediate effect.

For some reason, the Kee home group sometimes seems to be forgotten, and without a home group, no matching entries are found. Perhaps it’s a bug that the home group is forgotten, or perhaps it’s unintentional user error, but whatever it is, the impact is sudden and annoying but the fix is quick.

1 Like

Thanks for posting the solution.

One of the most common explanations for this sort of mysterious “forgetting” of Kee settings is due to a long-standing limitation in the KeePass merge algorithm. Thankfully there will soon be support for an improved algorithm which will reduce the likelihood of that happening. At the moment it’s pencilled in for the next release of KeePass, although whether it will have an immediate impact will depend upon exactly where else your KeePass KDBX file is being edited (which versions of KeePass, or other ports of KeePass, etc.). In any case, there is now some hope that things will eventually behave more predictably for everyone that accesses their KeePass database from more than one place. :slight_smile:

1 Like