Kee Firefox extension constantly nags me to unlock KeePass

Hi there …

new problem since the latest incarnation of the Kee Firefox extension:

Whenever I open some web page, KeePass pops up and wants to be unlocked. I presume that’s meant as a feature by the Kee extension, but I prefer KeePass to be locked until I really need it to be opened (because I want to log in somewhere).

Since other people might have other preferences, I’d like to suggest to make that feature optional (means: Give me a settings option to stop that behaviour).




for me it is also very annoying to be disrupted when calling most pages.
So please at least make this new features at least optional.


No such behaviour here.
There is no such behaviour with Firefox, KeePass and the Kee plugin.
I guess you have installed some other KeePass plugins.

I use Kee and Firefox and my KeePass database is nomaly locked.
There are never any pop-ups even if I enter a web page
for which KeePass and Kee plugin provide login data.
I have to unlock KeePass and only then Kee will provide the login data.
If I don’t unlock KeePass the Kee Icon in Firefox stays red, thats all what happens.
No pop-ups or anything else.

I don’t know what could lure Kee into insisting to have KeePass opened. Any idea ?
I’d supply any information needed … (besides my precious collection of credentials ;-))

I see this since nagghing behaviour since the last update of Kee …

The Firefox Kee plugin here is version 3.2.7 from 22. May 2019.
KeePass RPC plugin is version 1.10 (Pre-release).
KeePass is 2.43

The problem not even occurrs while opening new sites/tabs but also when switching between open tabs which is even more annoying. :frowning:

I notice the problem since version 3.3.12beta of the Kee plugin.
KeePass 2.43, KeePassRPC

So I suggest to go back to the stable Kee plugin 3.2.7

My system here:

KeePass 2.43
KeePassRPC 1.9
Kee 3.3.12beta

I could live with it until 3.3.12 comes stable, but THAT thing really needs to be fixed.

And I have to correct: It doesn’t pop up KeePass on browser stert (whit shows a blank page in my case), but on any occasion where some login fields could be suspected.

I can confirm to have encountered the same behavior.

Switching back to 3.2.7 of course solved the problem. But I would call it more a workaround. :wink:

Thanks for the feedback everyone. I’m not aware of any changes in 3.3 to alter the need for having at least one KeePass database unlocked when browsing pages with potential sign-in forms - it has always behaved in that way for me, as designed.

It sounds like I may have fixed one or more unknown bugs that were causing an unintentional behaviour that some people actually prefer to the previous behaviour.

I’ll definitely investigate in more detail before pushing 3.3 to the stable channel, both to get a better understanding of what changed and to investigate the possibility of making the behaviour controllable by an option.

If you haven’t already, please can you all include the Kee version, KeePassRPC version, KeePass version, web browser (Chrome or Firefox) and Operating system (including version if possible); any of those could potentially affect this behaviour.

First, thank you for developing Kee plugin for Firefox.

KeePass 2.43
KeePassRPC 1.9
Kee 3.2.7
Firefox 72.0.1 on Win10 (two separate FF instances, one installed, one portable)

This just started today, maybe an hour ago, and I came here to see if others were being spammed by Kee auth windows.

Contrary to suggestions that it’s limited to beta-version users, I’m still running good ole Kee 3.2.7 from May 17 2019 and neither KeePass, Firefox, nor Kee show any sign of having updated today. The only recent update was Firefox 72.0.1 a few days ago, but the problem didn’t start until today.

If I let an auth window sit without interaction it will disappear after a few moments and another will spawn in its place. It also opens an additional tab in Firefox. Right now my one Firefox looks like this:


Very disruptive, but since I’m already on the “old” 3.2.7 I can’t think of any quick fix to stem the flow of tabs. Suggestions welcome.

Edit: For now I have disabled Kee in all browsers and will only re-enable it when I need to log in somewhere.

24 hours later: Re-enabled Kee to log into a site and left it on as a test; it’s behaving itself so far today. What could have changed?

Update: Back at it again. What seemed to trigger it was disconnecting from my VPN service in anticipation of logging into PayPal. I noticed yesterday that the onset of the problem seemed to coincide with a change in my VPN connection status but wrote it off as unrelated. Seems like it might be a factor, actually.

Here my setup:

Kee 3.3.12beta
KeePass 2.43
Firefox 72.0.1 x64
Windows 10 Enterprise 1909 x64 (all updates installed)

Already reported

Addition: Windows 10 Pro x64 (Upgraded from 7Pro x64) Rev 1909, all updates done.

Update 2: I have downgraded all three Firefox instances from 3.2.7 to 3.1.21 but the problem persists unabated. It’s quite intolerable being tab-spammed constantly so I have to largely disable Kee.

Thanks everyone for the feedback. I’ve reconsidered how this aspect of the extension should work and the next beta release will only search for matching entries in connected sessions that contain unlocked databases. So if you have Kee Vault and KeePass both open but only one contains an unlocked database, only that will be searched for matches.

Since the KeePassRPC plugin in KeePass no longer receives any request for entries, it will no longer prompt you to unlock a database. The possible exception to this is if you have multiple databases open but some are locked. That’s a pretty rare situation to get into since typically the entire KeePass workspace gets locked along with all the open databases, but it can happen. If this becomes a problem, we can think about whether we want to make changes to KeePassRPC, perhaps the addition of some more advanced configuration options.

I have decided not to provide an option to enable the automatic unlock prompting since I think the Kee icon label/colour and lack of Kee field icons should provide enough of a clue to users that Kee is inactive. There’s still the issue of effective first-use understanding but even if this prompting behaviour is helping new users understand how Kee works, I don’t think that this benefit outweighs the likely confusion and/or irritation that would build up in the first few days of using the extension so any option would have to start disabled anyway.

I also can confirm that naggy behaviour.
I am using kee in firefox since some days and it basically works. I also have keepass open and I am logged in.
Every time I open up a new tab in firefox or when I am deleting one, the Kee-Authorization window pops up. Even if I open up websites that do not need a logon. When I close that authorisation tab it will immediatelly open again.
Currently that is so much annoying that I am thinking about deinstalltaion of kee and trying another plugin.

Hope that there is a fix soon.
Dis I understand correctly, that a downgrad to kee 3.2.7 resolves that problem?

Best Regards

I’m not sure your post is related to the rest of this topic. Please ensure you’ve read the troubleshooting guide so you fully understand what is happening and why. I’m not sure exactly what your goal is (i.e. what would be considered “not nagging”) but once you’ve read more about the various prompts that Kee needs to display at various times, feel free to break this out into another thread if required and update us with more detail about what you’re trying to achieve and what you’ve tried so far.

Hi Luckryrat
Naggy means, that every time I open an new tab or close one, the messagebox to unlock KeePass appears (exactly as the thread description describes it). That’s naggy. Espeacially when I am opening tabs that need no log in whatsoever.
But I fixed that issue by downgrading as proposed in older posts. So currently everything works for (as long as I do not update the addon)