Kee fills search fields with username


#1

Kee sometimes fills search fields with the site username.

I’ve met this behavior on Gitlab (SaaS and self-hosted, with different accounts) and DokuWiki (but I don’t have access to it anymore, it was in my former job).

On Gitlab, the search field has “name” as name attribute (because it’s “search by name”) but the Kee plugin is set to “username” for this entry.

This is particularly annoying in Gitlab because search is made while typing and all my projects disappear when Kee fills the search field, making Gitlab searching for a project named with my username…

Is there a way to prevent this behavior ? It may also be a security issue: I hope it would not do this with my password…

Thanks !


#2

Note that the only workaround I’ve found it to restrict the KeePass entry to the exact login URL instead of the hostname, but it doesn’t actually fix the issue as it’s curative only.


#3

You can block (or enable) the detection of certain forms for certain websites (or for all websites - though that would be more useful for entering localised translations of words like “name” rather than this specific issue with GitLab).


#4

I just had to set the ID for a form field in order for Kee to fill the proper box on uservoice.com, something I didn’t even know what possible, let alone how to do it, until I just came here to look into the problem. While that’s definitely the better way to do it, it would be nice if Kee would enter the username into the active field, since that would clearly be the one it needs to go in (obviously this would only apply when manually forcing Kee to enter the info, not on sites where it’s entered automatically). This would make it more user-friendly for people that wouldn’t know, or know how, to edit Kee’s settings for that site and enter the field’s ID.