Kee extension 3.7.8 (brave/chrome) won't connect to KeePass 2.4.7

Hello!
I’ve been using kee extension with KeePass on my Brave Browser for quite a while now, but since today i’m not able to connect the chrome addon to my KeePass Database. Tried with Firefox (addon ) and it connects immediately, tried with Chrome and this works too. Kee Addon on Brave Browser and Chrome Browser should be the same, but one connects while the other one won’t :frowning:

i’ve checked the “Troubleshooting” thread but there’s nothing that helps…
Port is correct (tried also to change the port in KeePass and Kee Addon, no success)
no relevant/blocking/proxy Browser Addons
no proxy configured
only one KeePassRPC.plgx file in plugins directory
JSFiddle says:

## Keefox / Keepass WebSocket Test
ERROR: undefined
Could not connect to KeepassRPC (This is bad)
DISCONNECTED

Here’s my KeePass -KPRPCDebug:

Logger initialised.
Client managers started.
RPC service started.
Starting KPRPCServer
Fleck says: Constructed server at ws://localhost:12546. Explicit port: 8181. Implicit port: 12546. Loopback only? True
Fleck says: Starting server at ws://localhost:12546. Loopback only? True
Fleck says: Server started at ws://localhost:12546
Started KPRPCServer
RPC server started.
KPRPC startup succeeded.

when starting Firefox or Chrome (and its Kee Addon) this (and some more) pops up:

Fleck says: Client connected from 127.0.0.1:49850 //firefox
Fleck says: Client connected from 127.0.0.1:50086 //chrome

I also tried to re-select the “Kee home group” in KeePass, but this doesn’t help either.
i would’ve tried to downgrade the chrome addon but i couldn’t find the previous versions :blush:

what more can i do?

2 Likes

Wow, incredible. Just got the same problem and diagnostics, Firefox works well and Brave doesn’t connect. Also JSFiddle says that it couldn’t connect even if I try it on Firefox

since yesterday/today?
iirc kee Addon got an update yesterday (on my brave browser)…

Just now, just went on my computer and noticed that it didn’t work. But I cannot remember if I’ve got an update

Same issue, same log
Keefox / Keepass WebSocket Test
ERROR: undefined
Could not connect to KeepassRPC (This is bad)
DISCONNECTED
Brave V1.21.73 win10 up to date

No problem under Firefox 86

i found this: Kee not work in Brave - #3 by Markco - Nightly Builds - Brave Community

Disable ‘ads and trackers’ in shields. The only solution.

disabled ads and trackers and kee connected immediately. reactivated ads and trackers again and the connection is still there. i’m curious on how long it will hold :slight_smile:

edit: apparently the it’s connected until you close the browser :roll_eyes:

1 Like

Great. Thank for the tip :wink:

This isn’t really a solution… That’s why I use Brave. And changing this setting always is gonna get really annoying. I don’t think that’s the problem though, since it worked fine until yesterday (?)

no, this is clearly not a solution, but it’s a workaround :wink:

Same problem.

Downgrading the Kee browser extension to version 3.6.27 in Brave did not fix it.

The setting “Trackers & ads blocking” to disabled solution provided by @narfinho as a temporary solution did work however.

Until there is a permanent fix I am leaving “Trackers & ads blocking” disabled and will use an ad blocker extension which obviously is not ideal as one of the main use cases for Brave is its inbuilt ad blocking.

i don’t even understand who (kee / brave) has to fix “it”. :man_shrugging:

Experiencing the exact same issue. Started KeePass.exe with –debug --KPRPCDebug option and this is what got logged:

Logger initialised.
Client managers started.
RPC service started.
Starting KPRPCServer
Fleck says: Constructed server at ws://localhost:12546. Explicit port: 8181. Implicit port: 12546. Loopback only? True
Fleck says: Starting server at ws://localhost:12546. Loopback only? True
Fleck says: Server started at ws://localhost:12546
Started KPRPCServer
RPC server started.
KPRPC startup succeeded.
Fleck says: Client connected from 127.0.0.1:52872
Fleck says: 359 bytes read
Fleck says: Error while reading. Exception: Fleck2.WebSocketException: Exception of type ‘Fleck2.WebSocketException’ was thrown.
at Fleck2.HandlerFactory.BuildHandler(WebSocketHttpRequest request, Action1 onMessage, Action onClose, Action1 onBinary)
at Fleck2.WebSocketConnection.CreateHandler(IEnumerable1 data) at Fleck2.WebSocketConnection.<>c__DisplayClassb.<Read>b__a(Int32 r) at Fleck2.SocketResult.Success[TResult](Action1 callback)
at Fleck2.SocketWrapper.<>c__DisplayClass7.b__6(SocketResult result)
at Fleck2.SocketFactory.<>c__DisplayClass16.b__15(Object )
Fleck says: Client connected from 127.0.0.1:52874
Fleck says: 542 bytes read
Fleck says: Building Hybi-14 Response
Fleck says: Sent 129 bytes
Fleck says: 454 bytes read
Fleck says: Sent 410 bytes
Fleck says: 215 bytes read
Fleck says: Sent 138 bytes
Fleck says: 285 bytes read
Fleck says: Sent 181 bytes
Fleck says: Sent 201 bytes
Fleck says: 285 bytes read
Fleck says: Sent 181 bytes
Fleck says: Sent 201 bytes
Fleck says: 285 bytes read
Fleck says: Sent 201 bytes
Fleck says: 285 bytes read
Fleck says: Sent 16265 bytes
Fleck says: Sent 16265 bytes

Found on Debian that with the latest Brave version (1.21.73) communication with KeePass does not work, but after downgrading to 1.20.110 with

apt-get install brave-browser=1.20.110

it works again.

Came here to also confirm the same issue. Not working on both Brave Devs on my dual boot laptop, both Windows and Fedora.

Upcoming fix to be released in Brave.

Until the Brave release arrives a temporary fix which worked for me is to add @@127.0.0.1 to Brave’s adblock filter list in brave://adblock/ as per this GitHub suggestion.

4 Likes

Hello,

Kee 3.7.7 beta extension does not work on Brave.
Kee says kee is not logged into the manager.
Look at the screenshot, keepass is well connected.
Please, how to go back to the old version that works

sorry i am using a french / english online translator


Error see screenshot
Capture d’écran 2021-02-13 103059

Brave is blocking access to 127.0.0.1 see the post: Kee not work in Brave - Nightly Builds - Brave Community

Resolved in :
Version 1.23.27 Chromium: 89.0.4389.86 (Build officiel) nightly (64 bits)

1 Like

@Marcosdw Thanks for reporting this and keeping us up to date with progress. I’m now merging the topic with another about the same Brave bug.