Kee extension 3.7.7 beta in Vivaldi is sluggish

Hi everyone,

this morning the extension auto updated to 3.7.7 beta (I don’t know why to the beta branch, I didn’t join beta testing channel) and now when i click on the Kee icon it opens very slowly. It is very slow with both the DB locked and unlocked.

You can see the strange behavior in this video:

I’m using Vivaldi browser, Windows 10 Pro, KeePass v2.46 and KeePassRPC v1.14.

I’ve already reinstalled the extension but this didn’t help.


Google Chrome beta version 3.7.7 now explains the “Beta” name.

As for the problem described, I don’t know of anything in v3.7 that could have caused this but if we can get some more details, we can try to come up with some theories.

Does the problem continue after you restarted your computer?

Does it happen if you try version 3.7.7 beta in another web browser (e.g. Chrome, Firefox, Edge)?

Do you have Kee installed on any other computers you can test on?

In case it’s not obvious, I haven’t seen this behaviour in any of these browsers that I test in before releasing any beta version.

Thanks for the quick reply!

Yes I restarted the PC.

I have another PC and I switched it on offline so that the extension could not be updated, with the version 3.6.27 it work correctly, you can see it in this video:

After that I connected the PC to Internet and let the extension be updated and the same problem occurred also in this PC, you can see it in this video:

Obviously the browsers in the two PCs are synched so maybe a common setting could cause the problem.

The second PC has Windows 10 Enterprise (1909). In both PCs I use ESET NOD32 as antivirus but disabling it didn’t help.

In KeePass I use KeeAnywhere to keep DBs synched.

Tomorrow I’ll try other browsers and I’ll let you know if the problem is only related to Vivaldi.

I tried the following browsers: Chrome, Opera and Firefox and with all of them the extension work correctly. So seems that the problem is only related to Vivaldi :confused:.

Can someone else try with Vivaldi and confirm that is the browser and not maybe a specific setting in my configuration?

Could there have been an automatic update to Vivaldi at the same time the Kee update was downloaded? I don’t use Vivaldi but perhaps there is a way to review which updates have been applied when?

Are there any other slow behaviours in the extension or is it just the initial opening of the main menu?

I’ll update the topic title to help others notice it.

No Vivaldi didn’t update at the same time of Kee. To update Vivaldi you receive a notification where there is also the changelog and have to confirm it manually.

Only the opening of the main menu is slow, if I do a research or create a new item it responds instantly. Also the autofill responds instantly.
The main menu of the other two extensions that I use (Google translate and uBlock ) opens instantly.

I did some other tests, I created a virtual machine with Win 10 20H2 and installed only Vivaldi and Kee without KeePass and without changing settings in the browser and the problem is the same. I tried two different version of Vivaldi: Vivaldi.3.5.2115.87 (x64) (older than the lastest one) and Vivaldi.3.6.2165.36 (x86). Here you can see all the old versions of Vivaldi: Vecchie versioni di Vivaldi | Vivaldi Browser

For the moment I unlock the DB directly from KeePass and not from Kee, so I don’t need to wait the opening of the main menu.

A couple of other things to try so we can narrow down where the issue might stem from:

Does the delay happen when you invoke the main menu from the keyboard shortcut? (Shift+Alt+V by default)

And what about the standalone password generator feature which you can launch from the right-click context menu on a page or via the keyboard shortcut Shift+Alt+G?

The shortcut Shift+Alt+V doesn’t work neither in Vivaldi nor in Chrome (in Chrome all setting are at default).

The shortcut Shift+Alt+G doesn’t work in Vivaldi, instead in Chrome works well.

Launching the standalone pw gen from the context menu in Vivaldi is slow, instead in Chrome is ok.

I checked shortcuts in Vivaldi and Shift+Alt+V and Shift+Alt+G by default are used for other functions, I deleted them but it still doesn’t work.

I can’t reproduce the problem on Vivaldi. Unless it’s a bug introduced in a different version of Vivaldi, there might be a problem with your personal profile. Presumably there is a “reset” feature similar to Firefox but I don’t use Vivaldi so can’t help further in that regard I’m afraid.

Vivaldi 3.6.2165.36 (Stable channel) (64-bit)
Revision bcf357a77b2f4450fd626b1bd424ecce4df171d3
OS Linux
JavaScript V8

Interesting, probably the problem is related to the Windows version of Vivaldi. I have already tried on a fresh install of Vivaldi in a Virtual Machine so I don’t think that it is related to the profile. Which distribution of Linux are you using? So I can create a VM to test Vivaldi on it.

Thanks for your support anyway.

Ubuntu 20.04.2 LTS

I installed it using the deb package from the Vivaldi download web page.

In Linux Kee works correctly also for me. So the problem seems only related to the Windows version of Vivaldi.

Some minutes ago I restarted the browser and Kee updated to version 3.7.8 and now the extension is working correctly.
For reference the problem appears to be present only in version 3.7.7 beta running on Vivaldi for Windows.
Maybe Vivaldi treats in a different way extensions labeled as beta? Maybe it enables some kind of debugging log that slows down the extension? It’s just a guess, I don’t know.

@luckyrat I really appreciated your support!

1 Like