Kee addon causes a network authentication window to popup when trying to log into home security cam

#1

I have an Amazon Wyze cam with modified flashed firmware that I use as a security cam. When I try to log into my cam, a “Network authentication” popup appears, which seems to be triggered by this extension (see screenshot).

I tried adding “dafang” url to the specific website section in options to blacklist it, but no matter how I add the site, I still get prompted with the “Network authentication” popup.

If I disable the “Kee” addon, then I do not get the popup, and I just get the normal popup to log into my cam.

Any ideas how I can prevent the Kee addon from causing the “Network authentication” popup?

Thanks for any suggestions.

#2

This is the network authentication feature of Kee. You can add the credentials for your “dafang” URL to KeePass or Kee Vault so that you can sign in to your cam by just clicking on the entry in the popup.

It’s strange that you have all those entries listed already - perhaps you’re running KeePass in debug mode and it’s generating a lot of random entries with GUIDs for a title?

There’s no way to disable this since it’s one of the core reasons that Kee exists - you’d need to either close your KeePass or Kee Vault database or otherwise configure the entries within it so that there are no matches for this website (perhaps try using the Kee home group feature if your password database is, or can be, structured with a suitable group hierarchy).

For maximum ease of use, you might consider adjusting the database as mentioned above so that you have only the one correct entry available for “dafang” and then enable the “When Kee finds only one matching network login (e.g. HTTP Auth), automatically login” option.

Because this “HTTP Auth” feature is so ancient and web browsers have limited support for it, the Kee options relating to whitelisting and other different configurations for certain web addresses can’t affect the behaviour of this feature.