Kee 2.0 beta testing


#1

Kee 2.0 is currently undergoing beta testing.

You can download the beta version from https://addons.mozilla.org/en-GB/firefox/addon/keefox/versions/2.0.0.20b2

The Google Chrome beta can be accessed at https://chrome.google.com/webstore/detail/kee/mmhlniccooihdimnnjhamobppdhaolme?hl=en

Some people are experiencing a stability problem with Firefox when Kee is installed. We have yet to identify what causes this, whether it is under the control of Kee or whether Mozilla will need to fix a bug in Firefox before Kee can function reliably. We hope that we can learn more as a result of having people use the add-on in Google Chrome too.

We have only a couple of weeks left before we must force all KeeFox users to upgrade to this version regardless of whether the add-on is as stable as we would like.

With that in mind, we are encouraging all Beta testers to upgrade to a beta version which is likely to suffer from this intermittent problem.

We do not know how prevalent the problem is, nor what causes it to affect some users but not others.

Since it does not affect luckyrat (the main Kee developer) it is not possible to progress any work on a fix unless someone else with development/debugging expertise can contribute to the issue.

If you come across the problem where Firefox freezes as described in https://github.com/kee-org/browser-addon/issues/27 please contribute to the resolution of the issue in any way you can so that we can try to eliminate it entirely before all KeeFox users are upgraded in a week or two.


#2

I’ve updated the topic to reflect that the beta is now published to all beta testers on AMO.

If you’ve installed any alpha versions of Kee, please upgrade to the Beta version now. It contains a few improvements from alpha 18 but as importantly it will receive automatic updates when new betas are published.

Thanks again for all your help so far and your patience if your system is suffering from the Firefox hanging problem.


#3

Chrome beta is now live!

It should behave broadly the same as in Firefox so I’ll be particularly interested in any new discussions about any differences you spot.


#4

I cannot seem to get the chrome plugin to work, i follow the install instructions, copied the KeePassRPC.plgx to the kee pass plugins folder, i got the kee loaded on chrome, but it shows wrong database loaded, and no entries in it.

EDIT:
Ok got it to work.
We first need to make a new entry (register with user+pass in a site), then a new branch will be created to our database call Kee backup …etc… If we move all of our database entries there, the kee can recognize them inside chrome. Not the most solid solution (at least for me, i have many sub headers inside my database), but works for now!


#5

I can’t this 2.0 beta to work in firefox. The symbol shows it as logged on but left or right clicking it does not bring up any menu. It is also not filling any passwords in. I went back to the release version and everything works.


#6

Hello,

I use Linux Mint 18.2 - Kernel 4.13.0-16-generic x86_64 - FF57b14 - Keepass 2.37 - RPC 1.7.3 - Kee Version 2.0.0.20b2

I still have :

_https://github.com/kee-org/browser-addon/issues/27

and

_https://github.com/kee-org/browser-addon/issues/39


Sorry, I use an online translator French / English


#7

tried the Chrome plugin: for me it worked just the same as the new beta in FF.

I’m more than happy that my favourite Keepass integration plugin will make the jump to FF 57 and greater: is there any way to donate some amount? :wink:


#8

Thanks for the update. I’m glad you’ve got it working now but you’re right that it doesn’t sound like an ideal solution. It’s certainly not what I expect to be required and it is not the case with my database. I’ll try to recreate the problem you describe when I next get some spare time but in the mean time, I’m wondering whether you’ve ever used KeeFox with this KeePass database before?

The “Kee backup” folder you mention is most likely the one that is created in order to store newly created passwords and should not be required to make Kee work.

Can you try right-clicking on the top/root group/folder in your database and select “Set as KeeFox startup group” and see if that now allows you to put your KeePass entries where you would like?


#9

Thanks for the info. For https://github.com/kee-org/browser-addon/issues/39 have you found or created a Firefox bug at bugzilla.mozilla.org? It’s possible that Mozilla aren’t aware of the bug and it’s not something that I can reproduce so I can’t really report the details to them but anything where resizing the window causes the problem to go away or in some way change is a definite Firefox bug and I’m sure they’d be interested to hear about it if they’re not already working on a fix.


#10

Glad the Chrome version is working for you. There’s a donate page at https://www.paypal.me/luckyrat

It’s currently linked only from the Mozilla add-ons page but I should probably publicise it more widely soon.


#11

@luckyrat, I would like to report bug #39 to Mozilla. But, sorry, I do not speak English, I use an online translator, which will be difficult to report the bug. It’s better to do it yourself, by giving the topic url #39 for Mozilla to understand the problem.


Sorry, I use an online translator French / English


#12

Hello again!
Thanks for your support, i really appreciate it!
I was using the same database to firefox, yes, and the solution you gave me (right-clicking on the top/root group/folder in your database and select “Set as KeeFox startup group”) did work for me, now it is fine!
Thanks again for your help!
If i can make some suggestions, if it’s possible of course, and if you find them useful:

  1. can you make the matched login entries appear when we click the toolbar icon, inside the same window, instead of having to click the “matched login entries”?
  2. Can you make the icon in the toolbar show some kind of visual difference when matched logins are found for this page?
  3. I saw that enabling kee 2.0 disabled chrome’s own password manager. Is there a way to leave it enabled while using kee at the same time?

Thanks again for all of your hard work, i was using keefox for years, and i am very happy to see it on chrome too! Keep up the good work!


#13

I am unable to launch KeePass from Kee because the link is missing from the entry box. It says “You are not logged in to your password database. Launch KeePass to enable Kee” (see screen shot below).

If I start KeePass separately, Kee will find it. The box then says “You are logged in to your ‘’ password database” and there is no link. The links to Generate New Password, Help Centre and Options are there and work. See screen shot below.

I am using Kee 2.0.0.20b2 (since I am using a Mac, Firefox requires me to use the beta version) with KeePass 2.35, KeePassRPC 1.7.3, mono 5.0.1, Firefox 56.0.2 and OS X 10.10.5.

I will try downgrading back to KeeFox 1.7.2b1, which will presumably fix the problem for me for now, but I thought you would want to know about it.

Pre-launch screen
52

Logged in screen
21

When I first started KeePass since Kee loaded, it asked for a new key for the link to Kee, but there was also an error message, which might be helpful:

02

I hope all of this is helpful.

Ian


#14

Installed this afternoon thinking I’d give myself a week before the official FF57 release to play with Kee, but my browser quickly started locking up and became completely unreliable. I’ll head over to GitHub and try to follow the conversation there to see if there’s anything I can contribute (unlikely, I suspect), but for now I’m uninstalling from my primary profile.


#15

@luckyrat,

For : _https://github.com/kee-org/browser-addon/issues/39
Read this : https://github.com/kee-org/browser-addon/issues/39#issuecomment-342675813

Thank’s


#16

A post was split to a new topic: Authentication code not accepted - window reappears immediately


#17

FWIW, I’ve had no issues with Firefox freezing or otherwise becoming unstable with Beta 3.


#18

Sorry to have been so slow on the uptake.

I now realise that I just didn’t read the Kee 2.0 Features page carefully. (Though I think that the new box when Kee is off could be worded so as to offer more of a hint to stupid KeeFox users like myself - e.g. “Launch KeePass externally to enable Kee”.)

Ian


#19

It’s a tough call. I think the simplicity of not talking at all about how one launches it is better for some users, especially those that haven’t used KeeFox before. That said, if we had a few more weeks before having to launch to all users, I’d consider some short-term adjustments to the wording. Unfortunately it’s too late to do that now.


#20

Hello,

Great plugin as always, today’s version looking slick as ever. Many thanks.

One problem I found yesterday when shopping on Newegg.com

I’ll show you how to reproduce. You must have a newegg.com account saved in keepass database to proceed:

  1. Add an item to cart that is shoprunner eligible ( newegg DOT com/Product/Product.aspx?Item=N82E16814131732 )
  2. Go to cart and click sign in to shoprunner (under shipping options)
  3. An in-window popup will open where you can enter shoprunner credentials
  4. Newegg credentials will auto-fill and will continue to override manually entered shoprunner login credentials
  5. Impossible to log in to shoprunner because newegg.com password is being autofilled every time text box is switched, must exit keepass to proceed.