IOS autofill not working

Autofill using the IOS app does not work.

Clicking the password entry box brings up the password autofill bar, clicking on Passwords opens the Kee Vault app and then closes without filling in the password and username. I have tried this with both facial recognition on and off… when off I am prompted for my PIN to open the app - it opens and then does nothing.

Am I missing any additonal settings for IOS integration? IOS 17.0.3

Thanks for letting us know.

Just so I’m sure I understand, you are saying that Kee Vault appears but then automatically disappears without you interacting with it (apart from the face recognition or PIN authentication to reach that point)?

I think if Kee Vault is appearing when you ask to autofill a password then everything is integrated correctly.

Has it ever worked for you or is this the first time you’ve tried?

We will look into whether the latest iOS update has caused problems, or if there is some other clue about what could cause this behaviour.

Your understanding is correct. I can share a video from my google drive if a visual representation helps?

I am a brand new customer and this is my first experience with keevault (used keepass on pc for almost 2years)

Just to add, this issue is not restricted to just apps - tried to login to the forums via safari and the same behaviour occurs.


I think it’s quite clear that you’re describing a situation where the Kee Vault autofill component crashes so a video is probably unlikely to reveal anything extra but thanks for the offer.

Did you import an existing KeePass database?

It’s useful to know that Safari is affected as well as other apps.

I am continuing to investigate what might cause this but as with every annual Apple upgrade, it is taking a long time just to get things working as they used to for the previous versions of iOS and Xcode (the apple development tool for creating apps). Once all of the necessary admin is complete I will be able to start exploring for clues about the actual problem.

No worries.

No import involved. My KeePass DB is strictly used on my work laptop for work-based credentials only. With KeeVault web & app being a brand new DB restricted to personal credentials.

I have updated to IOS 17.1 and the issue still persists in safari and apps. I have just tried Firefox for IOS and no luck there either.

Hopefully this helps narrow the cause down. If I could be of any more assistance, give me a shout

I’ve managed to get Kee Vault built and installed on iOS 17.1 now but it seems to work just fine so it seems likely that there is something specific about either your device or the underlying Vault file (kdbx) that Kee Vault has created with your data.

That is a very wide range of possible causes and I still have no idea of anything specific that can cause this behaviour so some deeper investigation is needed.

Since my last message I’ve been working on a new version of Kee Vault which will allow the export of detailed application logs, even from the Autofill component. I’ve reached a point where I’m reasonably confident that this will be possible but still have a bit of work to do before it’s useful and secure enough to be released.

Hopefully I’ll be able to get a beta version released in the next week or two but it’ll still be at least another couple of weeks after that before the new version would be approved by apple and pushed out to your device. Sorry that there is no quick fix in this case.

I’ll keep you up to date as we reach a point where some additional help would be useful and in the mean time, let me know if the behaviour changes at all.

Hey luckyrat,

Since you blame me personally for this not working /S I have completely removed the app (data inc.) from my device and reinstalled it.

I am happy to report that the KV works smoothly on safari and apps on IOS 17.1. Even wih apps that do not support autofill, the accounts list shows on screen and functionality is there.

Thanks for your help with this =)

Glad to hear it’s all fixed!

Perhaps there was a brief bug with one of the early versions of iOS 17 that got things stuck in a broken state. We may never know but I will of course keep working on the improvements to application logging (perhaps with a little less urgency) to make any future problems easier to solve.