Intermittent rendering problems in Kee v3.5.19+

Dropdown for the [found] keepass entries does not populate all of the time. “Kee” icon shows that entries have been located but the dropdown is blank. Not sure but right clicking instead and selecting “find matching logins” seems to populate the dropdown.
edited I just realized the Kee extension was just updated so the issue may be with the extension 3.5.19 instead of the plugin. Works the first time Kee is used after the browser is opened then fails after that.
I made additional tests and it seems to work just fine in Firefox. The problem appears in Chrome and the “New” Edge

According to Google, Kee version 3.5.19 is not yet available. I think that Edge relies on Google to approve new versions too. So it is therefore unlikely that this is a problem with v3.5.19.

It is unlikely that the latest KeePassRPC plugin has introduced the problem since it was focussed on only the recent security fixes. Unfortunately if that is the case, you would have to wait until Google allows you to install version 3.5.19.

If everything is working well with v3.5.19 in Firefox, you will just have to be patient until Google allow you to install that version in Chrome and Edge.

I tried removing and re-adding kee from the chrome store. They are serving the new version. Can I d/l the previous version?

Since yesterday in the evening the new Kee plugin is offered and updated by Google
ate least for me in Germany.
This also means for all versions of Chrome based Edge.
I have successfully tested with Firefox, Chrome, Chrome based Edge (Rel, Beta, Dev).

1 Like

After further experimenting, I discovered you have a new action for the kee icon in the google toolbar. Clicking that icon does list the entries for the web screen but clicking the kee icon in the username field does not.

Yeah it does look like Google have now published version 3.5.19. I’m not sure why they were telling me earlier this morning that they had not done so. Perhaps it takes some time for it to become available in every part of the world.

I still can’t reproduce the problem you describe though - every matched entry is displayed in the overlay that appears when clicking on the Kee icon in the username or password field.

Maybe there is a specific problem with one website you are using? Or maybe a different Chrome extension is now conflicting with Kee in some way?

Not confirmed here.
Clicking on the Kee icon in a username or password field also shows the matching entries.

I sent the Edge error log to your email address. Not sure at this point, but the error may only occur on certain sites. Thanks for looking

Also getting “anonymous function” error for “function __awaiter” in Edge debugger.

I emailed a stack trace and another capture from the Edge debugger. Will consider subscribing if we can figure this out. Thanks

I’ve received your emails but the attachments appear to simply be minified snapshots of Kee source code rather than any debug information. Even the stack trace in the most recent email doesn’t tell us anything I’m afraid.

We’ll need a lot more information about what is specific about your system before we can debug this.

For a start, it’s still not clear to me exactly how I would go about reproducing the problem. Does it happen only in Edge? In which version of Windows? And at which website URL?

Bear in mind that Edge has never been supported by Kee so if it does work, we consider this a bonus, although we are interested to learn more about that browser’s capabilities in case we would ever be able to release the extension for Edge.

How did you manage to install Kee in Edge? The last I heard, we would have to apply to a special Microsoft scheme to be allowed to release an extension for Edge but it sounds like there is now some other way that has been enabled without my knowledge.

Sent the requested info to your email. Thanks.

Thanks for the additional information via email. I have followed your instructions but unfortunately still can not reproduce the issue.

It is therefore likely that the problem is with some other extension that you have installed in the browser(s) that experience this problem. Or possibly some other malfunctioning security software on your Windows computer.

Bearing in mind that this list of matched entries is likely to be replaced later this year by a list that is more similar to the one in the new main popup on the browser toolbar, you might decide that lengthy investigation into the cause should be postponed for a while, if you can tolerate the problem by using the main popup or manually requesting to search for matches again via the context menu or keyboard shortcut.

I’m sorry that I’ve not been able to pinpoint the root of the problem. We may find that another person experiences a similar issue in future and can help you work it out by identifying some common factor between the computers that exhibit this behaviour.

For the record, with the specific URL removed in case you wish to keep it private, I’ve reproduced your instructions here. They assume you have more than one entry already stored in your password manager for the site in question.

Steps to reproduce:

  1. Start Edge or Chrome from a cold start [Not with edge/chrome running in the background]
  2. Navigate to https://… - Kee icon in username field shows 5 entries
  3. Click the icon and the drop down populates just fine [first time]
  4. Type “about:blank” in the navigation bar & press to clear the screen
  5. Navigate to https://… - Kee icon in username field shows 5 entries
  6. Click the icon and the drop down is empty

@proftech, I’m curious if you’re still having this issue. I have the same version of Kee, Keepass 2.45, and KeepassRPC On more than one machine (Windows 10) we’ve had problems with both the dropdown at the login form, and the Kee menu on the toolbar, are blank at times. I haven’t been able to find a pattern yet, but it is at least sometimes resolved by opening up Keepass (from minimized, hidden state). And on the machine I’m using right now, the dropdown by the login form works, but the toolbar menu is often blank.

I’ll keep watching it and try to find a pattern, but so far it seems to work whenever you watch it closely. :roll_eyes: :laughing:

Yes. Using 3.5.19 and KeepassRPC 1.13.0. Happens a lot of the time in the latest version of both Chrome and the newest Edge but can’t find a pattern. I’ve seen the toolbar dropdown empty as well as the login/password fields. When it happens, the only way I’ve found to get it to populate is to right click and select “search keepass”. I went back to using Firefox for the time being. It doesn’t have the issue. I prefer to use the dropdown in the login field because I find it more intuitive. I would like to switch to the new Edge browser but won’t until it is fixed. Will consider monthly support of Keepass if this can be corrected.

Well, I declare, I completely forgot to mention: my problem (and the 2 other Windows devices) is in Firefox. And not being a full-time computer user, I haven’t gathered much more info about it.

I’ve renamed this topic to help others find it and track it in future. I plan to try out the new Edge on Linux next month and will see if anything like this happens but in the mean time, please do let us know if there is any progress on being able to reliably reproduce the problem.

There may well be two different issues (one for Chromium and one for Firefox) but it’s not possible to determine that while it’s so intermittent so I’ll keep the entire discussion in this one place at least for the time being.