Help getting kee to recognize fields in poorly coded template form

kee
#1

Home Assistant html template…horrible! their password and username fields have no ids to help kee to fill them in. Can you give me some help. The two input tags are the ussername and password fields.

I do see a attribute of type=“password” for the password field but nothing for the username field that could be “grabbed”.

Kee at this point isn’t recognizing either field nor the form itself.

0 Likes

#2

@dlech I have attempted to get the HA folks to fix this

but in the meantime can you suggest how I get kee to recognize this form? The only thing to grab onto is is type=password attribute in the password input tag. Otherwise I see little way to make kee work on this page.

1 Like

#3

Is it the same behaviour in Chrome and Firefox?

This is the first real-world usage of shadow roots that I’ve come across. I’m not sure how well supported they are across browsers at the moment although I know that Firefox have only just enabled basic support for extensions to work with these types of page so using even versions as old as the current Extended Support Release (v60) might fail and I’m not even sure the support has made it to a Release version yet.

They are open shadow-roots so in theory there should be fewer problems than with closed ones but it’s a whole area that is still under active development in the browsers so I’ve not had a chance to fully work out whether and how this group of web features affects Kee.

0 Likes

#4

Yes I tried both when one didn’t work. I have no idea what your refer to (shadow roots) was only hoping that I could detect the fields as they are are. Not possible? Is a shadow root some kind of weird injection that you can’t parse?

Kee doesn’t seem to even recognize that the page url is one it should offer matching entries let alone finding the username and password fields.

0 Likes

#5

Shadow root (DOM) has been available in Chrome for a lot longer than Firefox (launched, possibly with bugs affecting extensions, at the end of 2018).

If you’re using the latest version of Firefox and Chrome the shadow roots might not be having any effect on this problem, but I can’t say for sure since I’ve never worked with them to the extent needed to find any bugs in the current browser versions.

I don’t know why (other than the possibility of the shadow roots affecting things) Kee doesn’t find these form fields. Looking in your debug log file might give some clues.

Unless Kee finds potentially relevant form fields to fill in, it won’t even look for entries matching the page URL. Standard type=password fields should be detected just fine though, hence my suspicion that this might relate to those shadow roots.

Is this website (or a demo of it) available somewhere public that I could access?

0 Likes

#6

It’s a self hosted home automation app. They have a demo site but doesn’t have that login page. :frowning:

I have one spun up a copy with a url you can access. I will message you with credentials and url.

0 Likes