Field Exclude Doesn't Work

Auto-Fill for account.kaspersky.com doesn’t work, because there are hidden fields “captcha” and “otp” and the field match ratio is only 0.5. When I add those as “form fields” with arbitrary values auto-fill will work, but since there is no option to “not fill” incorrect values the login process will abort.

Adding “captcha” and “otp” in the exclude-list doesn’t solve the problem, but apparently auto-fill should work when those fields would get disregarded