Failure to save login details for some sites

site-compatibility-investigate
#1

Hello,

My name is Ciprian and i just seek help for some sites that i can not save logins whatever I do.
My setup is Keepass (local database encrypted with key) + RPC plugin latest version + kee extension latest + Firefox latest version
I have keepass autofilling all my logins and works great always except a few sites:

https://accounts.firefox.com/signin

  • for this one is just imposible i can never save login details with default combo i use (never show save latest login)
    tried to save login manually with link and all stuff needed like id of user id of pass etc (does not fill in the login like any other site (does not even show kee icons in login user and pass)
  • all it works is auto-type but even that fails because it shows me a lot of sites and i always have to choose whitch one should i use (could not make a regex to show me only that window title)

https://www.linksyssmartwifi.com/ui/1.0.1.1605/dynamic/login.html

  • for this one is just imposible i can never save login details with default combo i use (never show save latest login)
    however i had it save one time and i had to swtch tab to another tab and back for login details to show up (this does not work anymore)

https://my.enel.ro/#!ApplicationLogin

  • for this i have login saved and it autofills it hoever mail (username) is always blanc even if it show it filled (to make it work i have to right click on user form and kee -> find matching logins, after this if i press login works)

Those are just a few, I will offer any assistance needed just to solve this.

Can u help?

Thanks in advance,
Ciprian

1 Like

#2

I’m working on some improvements for Kee v3.1 this week. Since there’s a small chance this will affect these sites, I will investigate them after doing that work.

Unfortunately, Mozilla prevent add-ons from working on accounts.firefox.com so it is not possible to log in to that website using a password manager extension like Kee. Auto-type is one option but failing that you’d just have to copy/paste.

0 Likes

#3

I will wait your updates with very much interest.

Thank you!

0 Likes

#4

I’ve pushed out the Kee 3.1 beta now.

https://www.linksyssmartwifi.com/ui/1.0.1.1605/dynamic/login.html

There were a few issues with this site. First, it has dozens of invisible form fields and no valid form to contain them. Kee 3.0 and lower will therefore ignore the form because it looks like a complex configuration page rather than a sign-in form.

I’ve got over that first hurdle by increasing the maximum number of form fields allowed (which is feasible now due to other improvements in Kee 3.1). That enables form saving :tada:

You’ll need to type your credentials correctly the first time though, or refresh the page between failed sign-in attempts (see this GitHub issue for more details)

The number and configuration of the invisible form fields seems to be unpredictable so:

  1. That explains why you were able to get it to save occasionally (it was only slightly above the previous field limit when I first looked so presumably can be lower for reasons)
  2. This prevents form filling because it looks to Kee like this is an almost entirely different form than the one it saved.

I’ve applied a lot of improvements to the relevant parts of Kee, which I think will make a difference on a variety of websites. Unfortunately it’s probably still not enough for this website to work perfectly, although you might be able to hack around with the form fields stored in the KeePass entry if you’re really bothered by it.

The good news is that Kee now matches entries for the form. The limitation is that it won’t auto-fill (it just looks too likely that it is not a sign-in form). It’s unlikely we can adjust this behaviour without breaking many other websites but I might have a go at it in a future Kee version, once the latest batch of changes have had some months to settle.

Compounding this limitation, it also looks like the page does something unusual that causes the Kee icon to be removed from the field after it’s been added initially. No idea what that could be but I suspect I can develop a workaround for it one day, especially if we ever find other websites with the same quirk. In the mean time, it shouldn’t stop you from using Kee on the page via the usual Ctrl-Shift-2 or Matched Logins button. It also only has this weird behaviour during the initial page load so switching between tabs will create the icon as expected.

https://my.enel.ro/#!ApplicationLogin

This looks fun too. I don’t remember seeing any website like this before, although it’s somewhat reminiscent of login forms from around 15 years ago in that it at least superficially appears to be taking steps to actively prevent form filling operations from succeeding. It might just be a bug in their website, either that or it’s been designed by someone with some outdated ideas of internet security. I must say I’m pretty confused about why they are storing entered usernames and passwords in some sort of local storage - again, I’ve never seen that before.

I’ll need more time to look into whether there is anything that can be done to enable auto-fill on this site in 3.2+; saving appears to be working fine using Kee 3.1 - I’m not sure if that was a problem before or not.

All in all, I’d be a bit concerned if I was putting sensitive data into that site so you might want to consider an alternative supplier/service (I have no idea what it does or whether the fact it stores entered passwords until one manually clears local storage is a concern for that use case, although I struggle to imagine any scenario in which that’s not a security flaw in the site design)

Others

You mentioned this was just 3 of the examples you have so it would be good to hear of other examples and whether they’re fixed with version 3.1.

0 Likes

#5

Hello,

I will test and report back my results.

Another sites that does not seem to save login or fill is my Home Assistant login, unfortunately i can not provide a site for that because is always a local network login under the form of http://192.168.0.xx:port-here/ or http://homeassistant.local:port-here/. I’ll try to attache a picture. Unfortunate i can not provide the code. I tried to copy it but it is endless. Maybe I can provide you some day with secure teamviewer so you can see the site.

I want to Thank you very much for your work and about my.enel.ro you are totally wright :)) a bunch of amateurs :slight_smile: No worry about that site.

0 Likes

#6

login_screen

This is how Home Assistant login looks, sry i forgot in the latest post to upload the image.

P.S. I want to test the new Firefox addon unfortunately I do not know how to install it on my Firefox, is not signed and my Firefox seems to refuse to install it under any circumstances. If not now when you release it I’ll test everything we spoke here.

Thanks again!

0 Likes