Error: opening file in Firefox

Hi, everyone.
For the last week or so, I have been having trouble signing into my Kee Vault through Firefox. The error I get is below. Can anyone assist in helping me figure out what it means?

Have you recently started to use Firefox in Private browsing mode? Or changed any Firefox setting that might affect whether it remembers / stores data for websites?

Perhaps a new Firefox add-on has been installed which aggressively deletes information stored in your browser?

Or you may have run out of disk space on your computer?

When you click OK, does your Vault load correctly? Are you able to save changes to it?

No to all above. I do think Firefox recently did one of its version updates but not sure what was changed with it.

When I click OK, my Vault does not load correctly. It navigates back to the login screen.

What is the file it is trying to look for?

The file is the contents of your Vault. It gets downloaded from “storage” (the Kee Vault server), stored in your browser’s “cache” and then decrypted and opened using your password. Normally, it is loaded from the browser cache first, since this is much faster, and then we check if there are any changes from a different device to load from storage a few seconds later. Since it fails to find the file in the browser cache, it should be loading it from storage instead, so this is a bit strange.

Are you able to access the Settings page of Kee Vault? The keyboard shortcut “CTRL and ,” may get you there if you can’t get to it from the sign-in page.

On the Settings page there is a section at the bottom called “Advanced” and an option to display the application logs. There may be further clues in there (feel free to copy/paste to here but double check it for anything sensitive just in case).

Do you have any other browsers on that computer that you could test with? Or any other devices you can try to access your Vault from?

This is what my advanced settings says:

I just tried it in Chrome and it works fine there! I had never tried another browser before. I also tried it on a different device with Firefox, and that also works fine.

I do need it in Firefox on my main machine though, since that is my main compatible browser.

Those log entries are only for the initial app startup and don’t contain any information about the attempt to load the vault from cache. So either the app is unexpectedly restarting after you click OK or you hadn’t reproduced the problem before taking that screenshot. Hopefully it’s the latter (sorry for not being clear that the log is reset when the app closes).

Glad to hear it is working elsewhere, so there is definitely going to be some way to get it working on your main Firefox again, we just have to work out the details.

There are two features of Firefox that we can try to further narrow down the cause of the problem.

First, another way to view logs, which may reveal additional information that is not visible in the Application Logs on the settings page:

When you have the Kee Vault tab selected, either Press Ctrl + Shift + i on your keyboard or use the Firefox main menu to open the “Web Developer Tools” (probably inside the “More tools…” submenu). Then in the Console tab which appears, you should be able to see some activity when you try to sign in to your account and experience the problem, or when you refresh/reload the tab to start the Kee Vault app again. You could then “copy all messages” or “save all messages to a file”.

The other thing to try is to restart Firefox in “Troubleshooting mode” (used to be called “Safe mode”) since this will allow you to test whether you can sign in while no browser extensions are active and a reduced set of your own settings and customisations are active. Make sure you don’t have any unsaved work in any tabs and then go to the main Firefox menu > Help > Troubleshoot Mode.

Let us know if the problem remains in troubleshooting mode or not. You can go to “Help > Turn Troubleshoot mode off” once you’ve done the test.

1 Like

Here is the correct logs.

I have tried your two suggestions:

(1) I copied all messages from the Web Developer Tools to a file. I don’t see anything obvious there that points to an issue. I can share this with you, if it helps.

(2) trouble-shooting mode gives the same error and the log files look the same.

Thanks for the additional information.

I have identified the current problem and am continuing to research how best to fix it automatically if it happens again in the future.

In the mean time, I have explained the situation below and am pleased to report that you are able to fix it manually yourself by deleting the site data for the Kee Vault website.

Doing so will effectively reset the Kee Vault app to the same experience as you saw when you signed in to a different browser recently. So, it’s not perfect since you’ll have to make a couple of configuration changes again but it is the easiest way to get everything back to normal.

To clear the site data in Firefox, you can click on the Secure padlock icon in the address bar and then “Clear cookies and site data”, then confirm that you want to remove the cookies and site data (we don’t actually use cookies but most sites do so that’s how Firefox labels this feature).

The problem that I’ll need to solve is that information in your browser says that the local cache version is newer than the one available on the server but the local version is missing/deleted. This was most likely a defensive posture to reduce the risk of data loss in the case that the network connection or Kee Vault servers went offline but on reflection, I’m not certain that it is a helpful feature - certainly in this case it has been a huge hindrance!

As for why the local version is missing, there are many possibilities including:

  1. Web browser or computer crashed during a save operation (Firefox does crash during automatic updates fairly frequently so this might be the most likely explanation)
  2. Computer ran out of disk space and deleted the Vault file
  3. Computer disk drive is failing and caused file corruption (I don’t know enough about Firefox internals to know if this hardware fault would instead lead to much more widespread problems such as Firefox failing to even start, but I suspect that it is a possible cause, albeit unlikely if the computer is otherwise working correctly)

I can’t say for certain that there isn’t a bug hiding somewhere in Kee Vault which could cause this to happen, but given the rarity of the problem, I suspect a temporary glitch with your browser or computer is more likely. Still, if the problem keeps happening or happens to others, we can try to look into the underlying cause in more detail - that will be tough because the problem is only likely to be noticed after the logs from the past session have been deleted.

Explanation of log

For the record, and in case you are interested, this is what the log entries tell us:


1-3: normal app startup.

4: You asked to open the Vault (file).

5: Our records indicate that the file cached on your machine has been modified since it was last uploaded. Therefore we load that local cache version as a priority over the remote version. We actually do that anyway for performance reasons but in this case we are stricter about the requirement to load from cache whereas in the normal situations we do in fact load from storage instead as the later log message claims.

6-7: We load the contents from the cache.

8: It turns out that the content of the cache file is empty so we report an error and give up. As previously mentioned, “Loading from storage instead” is incorrect and does not match the actual app behaviour.

9: The visible part of the app reports the error which you see on screen.

10+: This reports on how long the various steps in the sign-in process took, including things like validating you entered the correct password and downloading the latest modification time of your Kee Vault from the Kee Vault servers. (“KDBX download start” is actually a bit premature since we try the cache first).

1 Like

well, that worked! I so appreciate you looking into this and explaining everything to me!

btw - I can’t believe the fix was just to clear the cookies. so simple to have held me up for two weeks!

1 Like

Thanks for the feedback - I’m glad it is resolved :slight_smile:

Clearing the site data could solve various problems but it really shouldn’t be necessary if Kee Vault, the browser and computer are all working correctly. Since it does come with that risk of data loss if the Vault has failed to upload since the last change, it’s not something I’m very keen to promote as a “solution” in the general case.

It’s also a bit like the old “turn it off and on again” resolution to lots of computer problems - it’s great that it gets things up and running again relatively quickly but the downside is that there is then very little chance of finding out what actually went wrong or reducing the chance of the problem occurring again in the future.

Thanks for your patience as we worked through the possibilities.

1 Like