Crash during tutorial!


#1

As a new user, I was running the tutorial . . . when I got to “Complete step 3”, I clicked on “Update” from the firefox toolbar button . . . and keepass crashed :frowning: with a SIGABRT

Beginning of the stack trace is:

 [xcb] Too much data requested from _XRead
[xcb] This is most likely caused by a broken X extension library
[xcb] Aborting, sorry about that.
mono: xcb_io.c:732: _XRead: Assertion `!xcb_xlib_too_much_data_requested' failed.
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Windows.Forms.X11Keyboard.XCreateFontSet (intptr,string,intptr&,int&,intptr) [0x0000b] in <64229ce348bf414baa325904e6b85bb9>:0
  at System.Windows.Forms.X11Keyboard.CreateOverTheSpotXic (intptr,intptr) [0x00023] in <64229ce348bf414baa325904e6b85bb9>:0

=========================================
System info:
OS: OpenSUSE Leap 15.0 (4.12.14-lp150.12.25-default kernel)
Browser: Firefox Quantum 60.3.0esr (current for OpenSUSE)
Browser Add-ons: Kee - v2.4.15, KeepassHttp: v1.0.11, KeepassHttp-Connector: v1.8.4.2

Keepass: v2.38
KeepassRPC: 1.8.0.0

Do I need to modify my system config in some way? I searched the forum, but didn’t find any similar issues.

Thanks!

Dan


#2

FYI, this appears to be related to having KeepassHTTP running - if I disable the connector, I don’t get the crash . . . . :-))


#3

So it doesn’t sound like this has anything to do with Kee or KeePassRPC.

Although I know nothing about KeePassHttp(-Connector) my gut feeling is this is nothing their developers can directly fix either, although it probably wouldn’t hurt to make them aware of it.

It looks like a bug in Mono or less-likely, some system component like X-Windows. Make sure all of your system software and Mono is up to date as a first step but after that I’m afraid it’s unlikely we’ll be able to help much on this forum since it doens’t seem related to any of the software we develop.


#4

OK - thanks . . . . sort of my thoughts too. I’ve had some other Mono problems (maybe associated with the fact that I’m still on 5.10.1???). At any rate - it’s now stable with the Http stuff disabled.

Looks like [SOLVED] to me :slight_smile:

Thanks again!

Dan