Can't install in 59.0.2 (64-bit) on Windows 10


#1

So I just switched back from Chrome to FF. I tried to install Kee from mozilla.org and I got “This add-on requires a newer version of Firefox (at least version 56.0). You are using Firefox 52.0.” But I’m actually running 59.0.2 (64-bit) . On my Linux machine it just installed normally as one would expect.
I tried installing from the .xpi directly but FF won’t let me, even with the “xpinstall.signatures.required” switched to off.
Any ideas? Thanks.


#2

Did you download Kee from https://addons.mozilla.org/en-US/firefox/addon/keefox/ ?


#3

I am trying to…


#4

How strange.

Do you know if you have any other add-ons installed or perhaps a customised user agent string?

This doesn’t really appear to be a problem related to Kee since it is the addons.mozilla.org (AMO) website which is incorrectly detecting the version of your browser.

If changing or removing other addons doesn’t help, I suggest raising an issue on Mozilla’s GitHub account so they can help diagnose and fix the problem: https://github.com/mozilla/addons/issues/new