Auto submitting with Captcahs


#1

So for a few weeks now, on some sites kee is trying to auto login but the problem is that there is reCaptcha that I have to check off, but it doesn’t give me enough time to do so.

image


#2

The only option I can think of is to change the entry behavior for the affected sites. Open the individual site entry in KeePass, choose the Kee tab and under the General tab disable Auto-Submit.


#3

I have it set to not auto submit,

But for some reason it seems to be doing it. Only way for me to get it to stop is to disable kee

*on a side note this is using Vivaldi (chrome clone) I will test on Firefox soon.


#4

As noted in the text directly above your highlighted circle, the choices you make there in the Kee settings can be overridden in the edit entry in KeePass. I’m curious, did you check the settings for the affected in KeePass as per my original response, just to be sure? Otherwise, I’m out of ideas. And I don’t use Vivaldi, so I couldn’t answer whether this might be browser related.


#5

Yeah I checked the settings in keepass its not set to submit. do you know anyway of pulling a debug log?


#6

I haven’t used it, but I know logging can be enabled in the Kee options panel and viewed in the browser console. I seem to recall that Kee can’t write log files directly to the disk anymore due to limitations under webExtensions, but perhaps someone will correct me on that.


#8

This might be similar to the issue described in Kee is autosubmitting some entries ? If so, it’s not really about captchas at all but rather that some sites are choosing to auto-submit the login even when Kee only performs an auto-fill. So far Plesk is the only known example but maybe we have another one here.


#9

yes, you are correct it’s happening on a few of the websites I login to. now if i have 2 logins saved for a website, it doesn’t populate so then it wont auto submit.

*but i don’t have auto submit enabled for all websites. so don’t know why it’s still trying to submit.


#10

Please see Infinite page loading loop when Kee auto-fills a login form. I think the new information there might help you to retain auto-fill functionality without suffering from an instant log-in or infinite page reload behaviour.