Auto-fill not working on Google Account

compatibility

#1

I have searched this forum and the internet for half an hour and tried several options myself - to no avail. I would appreciate your pointers a lot!

  1. in Firefox 64 (or 65b) go to https://accounts.google.com
  2. get redirected to https://accounts.google.com/signin/v2 where you should fill in your email or phone and click ‘next’
  3. choose auto-fill for an account (through the hotkey or the icon)
    Result: the link ‘Forgot email?’ gets activated and the page “Enter your phone number or recovery email” is shown

When I manually enter an e-mail address and click ‘Next’, choose auto-fill, it does enter the password but then activates the ‘reveal password’ icon instead of submitting.

I feel silly for apparently being the only one with this problem. Have I changed a weird setting somewhere to make me the only one with this problem?

  • In ‘Edit Entry’ > ‘Kee’ > ‘Form fields’ I have tried to set the username as name=identifier, Id=identifierId page=1, password name=password page=2. Unsurprisingly, to no avail.
  • Kee doesn’t offer to store a new password when I remove an account and manually log in to Google.
  • I tried both Dutch and English login pages.

#2

The same happens to me since some days ago


#3

Have you solved that? I can’t user Kee to login to gmail :frowning: I tried to delete the KeePass account to auto-create with correct fields but after submitting the login form Kee doesn’t say nothing about adding the new entry.


#4

Kee can’t detect the “Next/continue/sign-in” buttons on the latest Google sign-in page.

Without knowing which button is relevant to the sign-in process, it is not possible to detect that a sign-in has occurred and therefore no offer to save the new password can be made.

When you have the option to “auto-fill and auto-submit when you select an entry” enabled, the auto-submit part of that relies on this same detection of the sign-in button. Since Kee gets that wrong right at that start of the process, it can’t “click” the correct button.

The technical reason for this is that Google have structured their website code in a way that tricks browser assistants like Kee into clicking the “button” called “Forgot email?” rather than the “text” called “Next”. Unfortunately, the visual appearance of the web page bears no resemblance to the code that creates it so there is no guarantee that any password manager will be able to detect which button to click (unless, as I would guess some do, the password manager develops specific exceptions for “unique” websites - as a free product there’s no way Kee could ever offer this expensive feature).

I’ll have another look at it in future in case it ever becomes feasible to workaround this without breaking all other websites but I can’t promise any improvement.

Right now, the best workaround for the sign-in problem is to switch the Kee setting to only “auto-fill when you select an entry” and then click the relevant button yourself.

There is no way to workaround the inability to save a new entry other than creating the entry manually in KeePass.


#5

Thx for the explanation and your time, hope you can find the key to solve that but at the moment I will configure Kee as you said.


#6

Kee 3.0 should work with the latest Google account sign-in page. You could install the beta or wait a bit until it is pushed to all Kee users.

I think it will work for any language but definitely works with English.