Auto-Fill doesn't work on specific site

autofill

#1

Hi. I’m having an issue with the autofill feature on this site: http://partner.novastor.de/partner-login

I noticed it doesn’t have any names for the fields, but just IDs. So I put the IDs in the entries under Kee > Form fields, but to no avail.

Username:
    Name: <empty>
    ID: cbiID0EBACAAOA

Passwort:
    Name: <empty>
    ID: cbiID0EBABAAOA

Ebay login is not recognized by Kee (Firefox + Chrome)
#2

I’ve had it happen on quite a few pages that either the data is not entered automatically (even after I manually specified the name and ID of the correct fields) or that it doesn’t even show the Kee symbol, nor fills in the data if I use Kee from the context menu.

A way to debug this would be greatly apprechiated. Like a way to know why it doesn’t automatically enter the data and why it doesn’t even find the form fields.


#3

Enabling debug logging in Kee options will offer you a lot more information to look through for debugging (in the browser console and add-on debugging console). It’s not especially refined though so you probably need to be reasonably technical and in some cases comfortable with searching the add-on source code to get from that information to an actionable change that needs to be made to your KeePass entries or to Kee. I’ve always wanted to provide a more user-friendly view of this sort of information but it will be a huge undertaking that I don’t know if I’ll ever get time for.


#4

I think I’ll be fine with the debug logs. I’m not new to programming. And I certainly understand your dilemma here.

I’ll keep you posted when I get to debug it.


#5

Ok. I figured out why it wasn’t even considering it at all. It was because the login field was in a frame with a completely different domain.

Now it doesn’t fill automatically. And that’s because of this (according to the log):

formFieldCount: 4, loginFieldCount: 2, formMatchedFieldCount: 2, fieldMatchRatio: 0.5
0762B8C721ED5F4FABB2B096ADCD8E67 will be forced to not auto-fill because the form field match ratio (0.5) is not high enough.

One field is dummy field, used for I don’t even know what, but it neither has a name, nor an ID, so I don’t know how I can make it autofill the field…
Also if I add the field in the entry for the language field the page keeps reloading over and over again, so I sadly can’t use that to tip the ratio over 0.5.

Any idea what I can do?

EDIT: I managed to get the dummy field in by letting Kee update the entry and manually removing the language entry.

It would still be very nice to have a way to tell Kee that it’s the right form and that it should autofill the values.


#6

A low match ratio for a “correct” form is usually due to the website changing it’s login form substantially or due to saving the registration form into Kee rather than the login form - it can’t be avoided in 100% of cases but you’re right that re-saving the entry usually resolves the problem no matter what its original cause.

The risk with forcing Kee to fill the form under this situation is that the large difference between the fields Kee expects to see and those actually in the form will result in the wrong fields being filled. So although it would be nice to have a sort of “auto-fix this entry to fill this form and save the result so I don’t have to do it again”, I’ve yet to identify a quick and reliable way to do this.

Maybe Kee could fill the form when forced to and then ask the user to confirm it worked OK? We’d have to be reasonably confident that a significant number of such force fills would succeed though and/or develop an extra feature to allow more detailed manipulation of the form field data within the context of the web page itself… but I’m at risk of running away with a dozen other related ideas at this point that I have no time to implement so I’ll leave it there :slight_smile:


#7

usps.com -> Sign In.
Re-saving the entry doesn’t help, the ratio is still too low:

Suitability of putting other field 0 into form field 0 (id: username) is 126
Suitability of putting password field 0 into form field 0 (id: password) is 126
Suitability of putting password field 0 into form field 1 (id: tPasswordNew) is 1
Suitability of putting password field 0 into form field 2 (id: tPasswordRetype) is 1
formFieldCount: 4, loginFieldCount: 2, formMatchedFieldCount: 2, fieldMatchRatio: 0.5

Also tried blacklisting tPasswordNew and tPasswordRetype, didn’t help as well.


#8

Hello everyone. I want to say “Thank you” to developers for great software KeeFox.
Also I want to ask for help with some pages, where Kee can’t insert my login/pass data.
It’s https://4pda.ru/forum/ and https://www.privat24.ua/#login

which information should I produce for my problem resolution?