Kee icon shows OFF and won't connect to running KeePass

I have the latest versions of Firefox, Kee, KeePass and the RPC plugin. OS is Windows 7 x64 with latest updates.

Firefox 59.0.1 (64-bit)
Kee Addon
KeePass 2.38
KeePass Plugin 1.7.3

The kee icon in the Firefox toolbar shows “OFF” with red background. It won’t connect to KeePass. KeePass is running, logged in and its workspace is unlocked. The RPC plugin is loaded.

I also tested the the JSFiddle thingy linked in the troubleshoot pages which says:

Keefox / Keepass WebSocket Test
ERROR: undefined
Could not connect to KeepassRPC (This is bad)

I ran keepass.exe with “–debug --KPRPCDebug=kee.log” and this is the log:

Logger initialised.
Client managers started.
RPC service started.
Starting KPRPCServer
Fleck says: Constructed server at ws://localhost:31001. Explicit port: 8181. Implicit port: 31001. Loopback only? True
Fleck says: Starting server at ws://localhost:31001. Loopback only? True
Fleck says: Server started at ws://localhost:31001
Started KPRPCServer
RPC server started.
KPRPC startup succeeded.

Is this correct? Should the server open by using port 31001?
I glanced at the code of the Firefox addon and the file “app.js” has this part:

configureConnectionURIs() {
const defaultWebSocketPort = 12546;

Is this a port mismatch between the addon client and the RPC plugin?

I do not use a proxy server.
AntiVirus (Norton in my case) was turned off during all tests.
I have not configured anything with ports.
All other Firefox addons were disabled during all tests.

Yes; you have configured your RPC plugin to listen on port 31001 so Kee can not connect to it. You can change it back to the default of 12546 in the KeePassRPC options dialog (in the KeePass Tools menu).

PS: The latest version is now 1.8.

1 Like

Thanks. It’s working now.

Actually, the RPC plugin was configured on port 31031. I’m not sure if I did that. However, I changed the browser plugin to that port number yesterday but it still didn’t work. It took a restart of KeePass itself and the key prompt appeared. I tried many things, but apparently not this. Set the default port on both ends now.

I have a similar problem.

Firefox 65.0
KeePass 2.39.1
Kee Addon

The icon shows OFF and when I click on “Options” button in about:addons, the browser opens the URL moz-extension://f13e1e25-3894-4502-934d-b630c4293776/settings/settings.html resulting en empty page.

RPC plugin is configured for the port 12546, as one would assume by default.

Can you verify that you have port 12546 set in the KeePass application as well as in the Firefox plugin?
KeePass application: Tools > KeePassRPC (KeeFox) options…
Firefox: open addons > click Kee settings > scroll down and check TCP/IP port

Both ports must be the same. Mine was different when I switched to a Firefox Quantum version.

Actually, that was the problem: I couldn’t open Kee options…
I have uninstalled Kee addon and installed it back and it started to work. So the problem is gone.