KEE always asks for new connection between Firefox and Kee

Hi, I’m out of clues about how to get kee to save the Kee Authorisation between Firefox Kee Plugin and KeePass. Every time I start KeePass I have to enter a new connection password. The “ask for a new password every time…” is not activated.
I tried several things:
-) reinstall Kee, KeePass, Firefox
-) deleted my Windows AD-Account with all the directories

no success. What can I do to avoid being forced to enter the connection password every time?

Those things wouldn’t typically help in this situation. The troubleshooting guide has a fair number of suggestions that are more likely to lead you to the solution.

thanks. I obviously have the following problem:

“If you keep being asked to enter this random password”

it could be caused by any of the following:

  • You have set Kee (and KeePassRPC) to the high security level - NO, my setting is Medium
  • You have set a very short expiry time for the authorisation - set to 8760hours
  • You have some other add-on or setting which prevents your web browser from saving the Kee authorisation key. - what could that be? I’ve installed noscript
  • Maybe some other reasons we’ve not come across yet (such as problems with your web browser or KeePass being unable to save their configuration files?)

other than the authorisation Kee and KeePass is working great.

I clear my firefox history and site data every time I close Firefox. Probably that’s a problem for Kee?

The problem occurs when I close KeePass. If KeePass is open (authorised) and I close and restart Firefox, no new authisation is necessary. If I close KeePass, there’s always the authorisation popup.

Take a look at my comment on that page and make sure you’re not having the issue described there.


thanks. That really solved my problem. I renamed the file in the program files folder and the problem was gone. The timestamp of the file in the program files folder was from Jan 2018. The file in the roaming folder was from today.

let me quote you here again for the solution:

I found another cause for the “I have to enter a password every time I load Kee” problem. I was experiencing this and was going to check here to see if I could figure out the problem, but then managed to solve it accidentally when I figured out something else. On Windows 7, I kept my KeePass config.xml file in KeePass’s Program Files directory, but on Windows 10, it didn’t occur to me this would cause problem due to KeePass not having the rights to modify the file. So it was saving a config file in the AppData\Roaming directory, but the one in the Program Files directory was overriding it, causing issues, one of which was the failure of KeePass to “remember” the authorization. So you may want to add that as a possible cause in that section, i.e. to make sure on Win10 a user-modified Keepass.config.xml file isn’t in the Program Files directory.

Glad it helped. I know the issue really frustrated me when I had it.

1 Like