Too many identical "matched login" to choose from


#1

I imported all my firefox passwords into KeePass. When I go to site, the username and password fields are not filled in by Kee. So I go to the Kee icon in firefox, and select “matched logins” and I am presented with many many identical ‘matched logins’ as I have many websites where I use my email address as the username. I cannot pick one, as I don’t know which one to pick. I thought Kee would only display the username for that domain? If this doesn’t work, is there any way to have Kee show me the URL, instead of the username? then I would be able to pick the correct username.
I really haven’t done any configuring, is there some configuration I need to do to get this to work?


#2

That’s correct. Maybe check that your import of passwords has set the correct URLs and it hasn’t created a lot of duplicate entries in your database.

If you have lots of logins for the same domain (e.g. you work with a domain that has a lot of subdomains like site1.mydomain.com and site2.mydomain.com) you can change the setting in the KeePass “Database settings” dialog to adjust the default matching behaviour to be more strict (i.e. “Hostname”) - or do that on specific entries as you prefer.


#3

Well, I went into KeePass and deleted all the duplicates. I hope that fixes the problem!

thanks luckyrat